summaryrefslogtreecommitdiff
path: root/app-portage/pram/pram-8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /app-portage/pram/pram-8.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'app-portage/pram/pram-8.ebuild')
-rw-r--r--app-portage/pram/pram-8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-portage/pram/pram-8.ebuild b/app-portage/pram/pram-8.ebuild
new file mode 100644
index 000000000000..61c091c9c5c6
--- /dev/null
+++ b/app-portage/pram/pram-8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Tool to ease merging Pull Requests and git patches"
+HOMEPAGE="https://github.com/mgorny/pram"
+SRC_URI="https://github.com/mgorny/pram/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-vcs/git
+ net-misc/wget[ssl]
+ virtual/editor
+ !dev-perl/Gentoo-App-Pram"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ app-crypt/gnupg
+ sys-apps/diffutils
+ )"