summaryrefslogtreecommitdiff
path: root/app-portage/pram/pram-10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /app-portage/pram/pram-10.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'app-portage/pram/pram-10.ebuild')
-rw-r--r--app-portage/pram/pram-10.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-portage/pram/pram-10.ebuild b/app-portage/pram/pram-10.ebuild
new file mode 100644
index 000000000000..b7e4516e80c2
--- /dev/null
+++ b/app-portage/pram/pram-10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Tool to ease merging Pull Requests and git patches"
+HOMEPAGE="https://github.com/mgorny/pram"
+SRC_URI="https://github.com/mgorny/pram/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-vcs/git
+ net-misc/wget[ssl]
+ virtual/editor
+ !dev-perl/Gentoo-App-Pram"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ app-crypt/gnupg
+ sys-apps/diffutils
+ )"