summaryrefslogtreecommitdiff
path: root/app-portage/portpeek/portpeek-2.1.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-portage/portpeek/portpeek-2.1.24.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-portage/portpeek/portpeek-2.1.24.ebuild')
-rw-r--r--app-portage/portpeek/portpeek-2.1.24.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-2.1.24.ebuild b/app-portage/portpeek/portpeek-2.1.24.ebuild
new file mode 100644
index 000000000000..f10e14f839ac
--- /dev/null
+++ b/app-portage/portpeek/portpeek-2.1.24.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.3.3
+ >=sys-apps/portage-2.3.5[${PYTHON_USEDEP}]"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}