summaryrefslogtreecommitdiff
path: root/app-portage/porthole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/porthole
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/porthole')
-rw-r--r--app-portage/porthole/Manifest6
-rw-r--r--app-portage/porthole/files/porthole-0.6.1-masking_status.patch17
-rw-r--r--app-portage/porthole/files/porthole-0.6.1-missing-attribute.patch14
-rw-r--r--app-portage/porthole/files/porthole-0.6.1-missing_import.patch19
-rw-r--r--app-portage/porthole/metadata.xml16
-rw-r--r--app-portage/porthole/porthole-0.6.1-r5.ebuild78
6 files changed, 150 insertions, 0 deletions
diff --git a/app-portage/porthole/Manifest b/app-portage/porthole/Manifest
new file mode 100644
index 000000000000..5a53e3be818a
--- /dev/null
+++ b/app-portage/porthole/Manifest
@@ -0,0 +1,6 @@
+AUX porthole-0.6.1-masking_status.patch 485 BLAKE2B 92188c56635ab69207dcee949303a09dc9d962bb6d0118205a4ec66d01e05f2d66f761f12ccf648230397a65772f0515460b373e526bbb368344f4d2d7030dd6 SHA512 5df59b9ceb47c8e6c5a3ca3c4777efcfdc7ee52e43f0a2121299ac777e2ecbbe707cb330a13355d35862dc5de7fa193fee846063e4825c4537d6c0b6d790bbbe
+AUX porthole-0.6.1-missing-attribute.patch 665 BLAKE2B ac282d0f7ef0f94d125520d25c3171b3f05bf42338f399b6bd7b82f09e9f6d0740e6df06c256b7179d9889b4c361b0ffa2954fd14f9a835d024feaf71499105a SHA512 e450d7d188b7762cebdfd33e6bc586c38e63fec80fe51fd500559587a85e6f5632ad3279d8e8a4bc37781e77f3f6f3df9af8b013f1725dbb47877642177d27d2
+AUX porthole-0.6.1-missing_import.patch 858 BLAKE2B 6b338ff4425d533e6f5a7033f2372032b7184ef3119a95cd5251ff92430223cbef3e95922850ee62416f9d7f2e0dde6df015a5cad1146e227c120c2e4a902630 SHA512 aa61359f9b0d53ffeb3a68bdcacf0010de2a789ea70b1bc0a1035d649ff3986e7fb44292fced65f5652475956d7a10d15907a4e6fa139854f7cdb4a7db1eaebd
+DIST porthole-0.6.1.tar.bz2 958696 BLAKE2B e4eb7493a66278cd7d16ac68304fe74ad8623054a95bb3dca84b0b8236f76cb9b0a92f446d1ffd95f907c29d703d93bdd48e8e5064485b69282e8680f5fcb658 SHA512 9bc1d79c587ad8228b9bb4eee6cb32559a5d7b6a9f4f6ece752fce9030f71fdbfd6158d7a2a055641b63df1f0a1c31995747e15b618de79cd8a7a56e4d8f634c
+EBUILD porthole-0.6.1-r5.ebuild 2059 BLAKE2B b448d7d9324c1c3cedf81c30b68059c8075047226b4115c341535a1870afcf49c0eb7dd2fbd531ea1ba4ae60fff3a7d2a6be643b65d6cdd745b9fc8c4cb33ea8 SHA512 3eeb6a7fd489c4d9b4e723af91e65b269d509f78399b5557ffa10cf41343219264d5fae84e5053325fdbcd06f3952b3a77326c9f120747dc6c0007087e46e34a
+MISC metadata.xml 519 BLAKE2B 2c5fd18fa8f91cecdebd9e89292c1862e11e126cbf710db17af3358e92bd2a7abd30e5a7ff925b33c446d9d7c6937f2e3d19c171e8c35c2bbee243e2f9339947 SHA512 d149c76b00d1a0c2b3593f90b45b944de122498606d86cb90f992beb2a727bb3b32f610e823c0d0ad0377538616447698acc110c6f152860844a53610d531220
diff --git a/app-portage/porthole/files/porthole-0.6.1-masking_status.patch b/app-portage/porthole/files/porthole-0.6.1-masking_status.patch
new file mode 100644
index 000000000000..e626fbb3c58f
--- /dev/null
+++ b/app-portage/porthole/files/porthole-0.6.1-masking_status.patch
@@ -0,0 +1,17 @@
+Index: porthole/backends/portagelib.py
+===================================================================
+--- porthole/backends/portagelib.py (revision 1209)
++++ porthole/backends/portagelib.py (working copy)
+@@ -452,7 +452,11 @@
+
+
+ def get_masking_status(ebuild):
+- return portage.getmaskingstatus(ebuild)
++ try:
++ status = portage.getmaskingstatus(ebuild)
++ except KeyError:
++ status = ['deprecated']
++ return status
+
+
+ def get_masking_reason(ebuild):
diff --git a/app-portage/porthole/files/porthole-0.6.1-missing-attribute.patch b/app-portage/porthole/files/porthole-0.6.1-missing-attribute.patch
new file mode 100644
index 000000000000..aa011a174b17
--- /dev/null
+++ b/app-portage/porthole/files/porthole-0.6.1-missing-attribute.patch
@@ -0,0 +1,14 @@
+diff -uNr porthole/db/user_configs.py.old porthole/db/user_configs.py
+
+--- porthole/db/user_configs.py.old 2010-11-27 13:34:35.000000000 +0600
++++ porthole/db/user_configs.py 2010-11-27 13:31:24.000000000 +0600
+@@ -364,7 +364,7 @@
+ debug.dprint("USER_CONFIGS: set_user_config(): add: " +
+ "%s,\n remove: %s " %(str(add),str(remove)))
+ set_config.set_user_config(filename=file, name=name, ebuild=ebuild,
+- comment=comment, username=privileges.USER,
++ comment=comment, username=privileges.user,
+ add=add, remove=remove)
+ self.set_config_callback()
+ else:
+ \ No newline at end of file
diff --git a/app-portage/porthole/files/porthole-0.6.1-missing_import.patch b/app-portage/porthole/files/porthole-0.6.1-missing_import.patch
new file mode 100644
index 000000000000..33c9e4ee3353
--- /dev/null
+++ b/app-portage/porthole/files/porthole-0.6.1-missing_import.patch
@@ -0,0 +1,19 @@
+--- porthole/db/user_configs.py 2010/03/20 12:32:29 1217
++++ porthole/db/user_configs.py 2010/03/20 14:10:46 1218
+@@ -36,6 +36,7 @@
+ from porthole import backends
+ portage_lib = backends.portage_lib
+ from porthole.utils import debug
++from porthole.privilege import controller as privileges
+
+ ## set up this module to act as a user configs data server,
+ ## watch the user configs for changes and auto update
+@@ -363,7 +364,7 @@
+ debug.dprint("USER_CONFIGS: set_user_config(): add: " +
+ "%s,\n remove: %s " %(str(add),str(remove)))
+ set_config.set_user_config(filename=file, name=name, ebuild=ebuild,
+- comment=comment, username=priviliges.USER,
++ comment=comment, username=privileges.USER,
+ add=add, remove=remove)
+ self.set_config_callback()
+ else:
diff --git a/app-portage/porthole/metadata.xml b/app-portage/porthole/metadata.xml
new file mode 100644
index 000000000000..860c6eb9ffd5
--- /dev/null
+++ b/app-portage/porthole/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tools-portage@gentoo.org</email>
+ <name>Gentoo Portage tools team</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ <description>Upstream Maintainer (please CC on bugs)</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">porthole</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/porthole/porthole-0.6.1-r5.ebuild b/app-portage/porthole/porthole-0.6.1-r5.ebuild
new file mode 100644
index 000000000000..3697141e3779
--- /dev/null
+++ b/app-portage/porthole/porthole-0.6.1-r5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=(python2_7)
+PYTHON_REQ_USE="threads(+),xml(+)"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A GTK+-based frontend to Portage"
+HOMEPAGE="http://porthole.sourceforge.net"
+SRC_URI="mirror://sourceforge/porthole/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="nls"
+LANGS="de pl ru vi it fr tr"
+
+RDEPEND="
+ || (
+ >=sys-apps/portage-2.1[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ gnome-base/libglade:2.0
+ dev-python/pygtksourceview:2[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.14 )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-masking_status.patch" # bug 307037
+ "${FILESDIR}/${P}-missing_import.patch" # bug 323179
+ "${FILESDIR}/${P}-missing-attribute.patch" #bug 323179
+)
+
+src_compile(){
+ # Compile localizations if necessary
+ if use nls ; then
+ cd scripts
+ ./pocompile.sh -emerge ${LINGUAS} || die "pocompile failed"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc TODO README NEWS AUTHORS
+
+ keepdir /var/log/porthole
+ fperms g+w /var/log/porthole
+ keepdir /var/db/porthole
+ fperms g+w /var/db/porthole
+
+ # nls
+ if use nls; then
+ # mo directory doesn't exists with nls enabled and unsupported LINGUAS
+ [[ -d porthole/i18n/mo ]] && domo porthole/i18n/mo/*
+ fi
+}
+
+pkg_preinst() {
+ chgrp portage "${D}"/var/log/porthole
+ chgrp portage "${D}"/var/db/porthole
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Porthole has updated the way that the upgrades are sent to emerge."
+ einfo "In this new way the user needs to set any 'Settings' menu emerge options"
+ einfo "Porthole automatically adds '--oneshot' for all upgrades selections"
+ einfo "Other options recommended are '--noreplace' along with '--update'"
+ einfo "They allow for portage to skip any packages that might have already"
+ einfo "been upgraded as a dependency of another previously upgraded package"
+ einfo
+}