summaryrefslogtreecommitdiff
path: root/app-portage/portage-utils/portage-utils-0.95.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-20 13:07:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-20 13:07:51 +0100
commit30114ae8ef07a32fea1e44a10b61f98c84142645 (patch)
tree1f5829906b913ee4637e04254cc50ffc1faab519 /app-portage/portage-utils/portage-utils-0.95.ebuild
parentaaa44376d7162304219748a3b6771d9a26fc80fe (diff)
gentoo auto-resync : 20:07:2023 - 13:07:51
Diffstat (limited to 'app-portage/portage-utils/portage-utils-0.95.ebuild')
-rw-r--r--app-portage/portage-utils/portage-utils-0.95.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/app-portage/portage-utils/portage-utils-0.95.ebuild b/app-portage/portage-utils/portage-utils-0.95.ebuild
deleted file mode 100644
index b70c8d6732ac..000000000000
--- a/app-portage/portage-utils/portage-utils-0.95.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Small and fast Portage helper tools written in C"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3 autotools
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage-utils.git"
-else
- SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="openmp +qmanifest +qtegrity static"
-
-RDEPEND="
- qmanifest? (
- !static? (
- app-crypt/gpgme:=
- app-crypt/libb2:=
- dev-libs/openssl:=
- sys-libs/zlib:=
- )
- )
- qtegrity? (
- !static? (
- dev-libs/openssl:=
- )
- )"
-DEPEND="${RDEPEND}
- qmanifest? (
- static? (
- app-crypt/gpgme[static-libs]
- app-crypt/libb2[static-libs]
- dev-libs/openssl[static-libs]
- sys-libs/zlib[static-libs]
- )
- )
- qtegrity? (
- static? (
- dev-libs/openssl[static-libs]
- )
- )"
-BDEPEND="virtual/pkgconfig"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_prepare() {
- default
- [[ ${PV} == *9999 ]] && eautoreconf
-}
-
-src_configure() {
- use static && append-ldflags -static
-
- econf \
- --disable-maintainer-mode \
- --with-eprefix="${EPREFIX}" \
- $(use_enable qmanifest) \
- $(use_enable qtegrity) \
- $(use_enable openmp)
-}