summaryrefslogtreecommitdiff
path: root/app-portage/nattka/nattka-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-portage/nattka/nattka-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-portage/nattka/nattka-9999.ebuild')
-rw-r--r--app-portage/nattka/nattka-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-portage/nattka/nattka-9999.ebuild b/app-portage/nattka/nattka-9999.ebuild
new file mode 100644
index 000000000000..8d274617226a
--- /dev/null
+++ b/app-portage/nattka/nattka-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+EGIT_REPO_URI="https://github.com/mgorny/nattka.git"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-util/pkgcheck[${PYTHON_USEDEP}]
+ dev-vcs/git
+ sys-apps/pkgcore[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "NATTkA can optionally use:"
+ elog " dev-python/networkx"
+ elog "to sort 'apply' output in dependency order."
+}