summaryrefslogtreecommitdiff
path: root/app-portage/nattka/nattka-0.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-31 14:19:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-31 14:19:51 +0000
commitea5bad4d0ba1eb937df22adb7f6cc57ea77f03d8 (patch)
tree444d798059985f0e993cb7582231243cd4c5d083 /app-portage/nattka/nattka-0.4.1.ebuild
parent6989a301768c924a6014fdce19b28de541ad557a (diff)
gentoo auto-resync : 31:12:2022 - 14:19:51
Diffstat (limited to 'app-portage/nattka/nattka-0.4.1.ebuild')
-rw-r--r--app-portage/nattka/nattka-0.4.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-portage/nattka/nattka-0.4.1.ebuild b/app-portage/nattka/nattka-0.4.1.ebuild
new file mode 100644
index 000000000000..e0b583125d4c
--- /dev/null
+++ b/app-portage/nattka/nattka-0.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="
+ https://github.com/projg2/nattka/
+ https://pypi.org/project/nattka/
+"
+SRC_URI="
+ https://github.com/projg2/nattka/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="depgraph-order"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-util/pkgcheck[${PYTHON_USEDEP}]
+ dev-vcs/git
+ sys-apps/pkgcore[${PYTHON_USEDEP}]
+ depgraph-order? (
+ dev-python/networkx[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ >=dev-python/flit_core-3.7.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest