summaryrefslogtreecommitdiff
path: root/app-portage/layman/layman-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-portage/layman/layman-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-portage/layman/layman-9999.ebuild')
-rw-r--r--app-portage/layman/layman-9999.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-portage/layman/layman-9999.ebuild b/app-portage/layman/layman-9999.ebuild
index e8ba2aeb5168..b9c60ed0d3d4 100644
--- a/app-portage/layman/layman-9999.ebuild
+++ b/app-portage/layman/layman-9999.ebuild
@@ -68,6 +68,15 @@ python_test() {
unset suite
}
+python_compile_all() {
+ default_python_compile_all
+ # Generate man page. only required for 9999
+ if [[ ${PV} == *9999 ]] ; then
+ # override MAKEOPTS to prevent build failure
+ emake -j1 -C doc
+ fi
+}
+
python_install_all() {
distutils-r1_python_install_all