summaryrefslogtreecommitdiff
path: root/app-portage/kuroneko/kuroneko-0.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-portage/kuroneko/kuroneko-0.1.2.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-portage/kuroneko/kuroneko-0.1.2.ebuild')
-rw-r--r--app-portage/kuroneko/kuroneko-0.1.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/kuroneko/kuroneko-0.1.2.ebuild b/app-portage/kuroneko/kuroneko-0.1.2.ebuild
new file mode 100644
index 000000000000..9b74e4af13e3
--- /dev/null
+++ b/app-portage/kuroneko/kuroneko-0.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Vulnerability checker using data scraped from Gentoo Bugzilla"
+HOMEPAGE="https://github.com/mgorny/kuroneko/"
+SRC_URI="
+ https://github.com/mgorny/kuroneko/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="scraper"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ sys-apps/pkgcore[${PYTHON_USEDEP}]
+ scraper? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ )"
+BDEPEND="
+ test? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest