summaryrefslogtreecommitdiff
path: root/app-portage/hashgen/hashgen-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-portage/hashgen/hashgen-1.1.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/hashgen/hashgen-1.1.ebuild')
-rw-r--r--app-portage/hashgen/hashgen-1.1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/app-portage/hashgen/hashgen-1.1.ebuild b/app-portage/hashgen/hashgen-1.1.ebuild
deleted file mode 100644
index eacb1653fc3e..000000000000
--- a/app-portage/hashgen/hashgen-1.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="Manifest generation and verification tool written in C"
-HOMEPAGE="https://prefix.gentoo.org/"
-GITHASH="2ea68e88531288c29c5533440d63da6c8136d477"
-SRC_URI="https://gitweb.gentoo.org/repo/proj/prefix.git/plain/scripts/rsync-generation/hashgen.c?id=${GITHASH} -> ${P}.c"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x64-macos ~sparc-solaris ~x64-solaris"
-IUSE="+openmp"
-
-DEPEND="
- openmp? (
- || ( >=sys-devel/gcc-4.2:*[openmp] sys-devel/clang-runtime:*[openmp] )
- )
- app-crypt/libb2
- dev-libs/openssl:*
- sys-libs/zlib
- app-crypt/gpgme
-"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- mkdir "${S}" || die
- cp "${DISTDIR}"/${P}.c "${S}"/${PN}.c || die
-}
-
-src_compile() {
- v() {
- echo "$@"
- "$@"
- }
-
- local openmp=
- use openmp && tc-has-openmp && openmp=-fopenmp
-
- [[ ${CHOST} == sparc-*-solaris2* || ${CHOST} == i?86-*-solaris2* ]] \
- && append-flags -D_FILE_OFFSET_BITS=64
-
- v $(tc-getCC) -o hashgen ${openmp} ${CFLAGS} \
- $(pkg-config openssl --libs) \
- $(gpgme-config --libs) \
- -lb2 -lz ${LDFLAGS} ${PN}.c || die
-}
-
-src_install() {
- dobin hashgen
- cd "${ED}"/usr/bin || die
- ln -s hashgen hashverify || die
-}