summaryrefslogtreecommitdiff
path: root/app-portage/hashgen/hashgen-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /app-portage/hashgen/hashgen-1.1.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'app-portage/hashgen/hashgen-1.1.ebuild')
-rw-r--r--app-portage/hashgen/hashgen-1.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-portage/hashgen/hashgen-1.1.ebuild b/app-portage/hashgen/hashgen-1.1.ebuild
new file mode 100644
index 000000000000..eacb1653fc3e
--- /dev/null
+++ b/app-portage/hashgen/hashgen-1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Manifest generation and verification tool written in C"
+HOMEPAGE="https://prefix.gentoo.org/"
+GITHASH="2ea68e88531288c29c5533440d63da6c8136d477"
+SRC_URI="https://gitweb.gentoo.org/repo/proj/prefix.git/plain/scripts/rsync-generation/hashgen.c?id=${GITHASH} -> ${P}.c"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x64-macos ~sparc-solaris ~x64-solaris"
+IUSE="+openmp"
+
+DEPEND="
+ openmp? (
+ || ( >=sys-devel/gcc-4.2:*[openmp] sys-devel/clang-runtime:*[openmp] )
+ )
+ app-crypt/libb2
+ dev-libs/openssl:*
+ sys-libs/zlib
+ app-crypt/gpgme
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ mkdir "${S}" || die
+ cp "${DISTDIR}"/${P}.c "${S}"/${PN}.c || die
+}
+
+src_compile() {
+ v() {
+ echo "$@"
+ "$@"
+ }
+
+ local openmp=
+ use openmp && tc-has-openmp && openmp=-fopenmp
+
+ [[ ${CHOST} == sparc-*-solaris2* || ${CHOST} == i?86-*-solaris2* ]] \
+ && append-flags -D_FILE_OFFSET_BITS=64
+
+ v $(tc-getCC) -o hashgen ${openmp} ${CFLAGS} \
+ $(pkg-config openssl --libs) \
+ $(gpgme-config --libs) \
+ -lb2 -lz ${LDFLAGS} ${PN}.c || die
+}
+
+src_install() {
+ dobin hashgen
+ cd "${ED}"/usr/bin || die
+ ln -s hashgen hashverify || die
+}