summaryrefslogtreecommitdiff
path: root/app-portage/hackport/hackport-0.5.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/hackport/hackport-0.5.5-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/hackport/hackport-0.5.5-r1.ebuild')
-rw-r--r--app-portage/hackport/hackport-0.5.5-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-portage/hackport/hackport-0.5.5-r1.ebuild b/app-portage/hackport/hackport-0.5.5-r1.ebuild
new file mode 100644
index 000000000000..35d3380ce9ad
--- /dev/null
+++ b/app-portage/hackport/hackport-0.5.5-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.4.9999
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hackage and Portage integration tool"
+HOMEPAGE="http://hackage.haskell.org/package/hackport"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # tests are broken: need path to ebuild tree
+
+RDEPEND="
+ || (
+ <sys-apps/portage-2.3.0
+ sys-apps/portage-mgorny
+ app-portage/repoman
+ )
+ dev-haskell/async:=
+ dev-haskell/base16-bytestring:=
+ dev-haskell/base64-bytestring:=
+ dev-haskell/cryptohash:=
+ dev-haskell/ed25519:=
+ dev-haskell/extensible-exceptions:=
+ dev-haskell/hashable:=
+ >=dev-haskell/http-4000.0.3:=
+ dev-haskell/missingh:=
+ dev-haskell/mtl:=
+ >=dev-haskell/network-2.6:=
+ >=dev-haskell/network-uri-2.6:=
+ dev-haskell/old-locale:=
+ dev-haskell/old-time:=
+ dev-haskell/parsec:=
+ dev-haskell/random:=
+ dev-haskell/regex-compat:=
+ dev-haskell/split:=
+ dev-haskell/stm:=
+ >=dev-haskell/tar-0.5:=
+ >=dev-haskell/xml-1.3.7:=
+ dev-haskell/zlib:=
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hunit )
+"
+src_install() {
+ haskell-cabal_src_install
+ doman man/hackport.1
+}