summaryrefslogtreecommitdiff
path: root/app-portage/gpyutils/gpyutils-0.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:17:25 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:17:25 +0100
commit62f82c107c3904ac6917ece47301d2999c7dd90e (patch)
tree48ddfc2291e77d0e3ad80f6d7c5f403d84ae8414 /app-portage/gpyutils/gpyutils-0.2.2.ebuild
parent7fe80ac8764ccbf354f82029a6bce4f96dbb8d5d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/gpyutils/gpyutils-0.2.2.ebuild')
-rw-r--r--app-portage/gpyutils/gpyutils-0.2.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-portage/gpyutils/gpyutils-0.2.2.ebuild b/app-portage/gpyutils/gpyutils-0.2.2.ebuild
new file mode 100644
index 000000000000..d46dffd50704
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.2.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="https://github.com/mgorny/gpyutils/"
+SRC_URI="https://github.com/mgorny/gpyutils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.9[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}