summaryrefslogtreecommitdiff
path: root/app-portage/golop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/golop
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/golop')
-rw-r--r--app-portage/golop/Manifest4
-rw-r--r--app-portage/golop/golop-0.0.1.ebuild31
-rw-r--r--app-portage/golop/golop-9999.ebuild31
-rw-r--r--app-portage/golop/metadata.xml17
4 files changed, 83 insertions, 0 deletions
diff --git a/app-portage/golop/Manifest b/app-portage/golop/Manifest
new file mode 100644
index 000000000000..0183928406ab
--- /dev/null
+++ b/app-portage/golop/Manifest
@@ -0,0 +1,4 @@
+DIST golop-0.0.1.tar.gz 8316 BLAKE2B a1e51d55ef4744f3a6d00bcba145a410c9f67e78107bb990f6195ec5912d875e31308556e5d1e993917526121857ece09bd894556328e37453ea98d0a306f6d8 SHA512 650ceeb2607871d029f97ced882d661d1045dce6792c2c43f9c79076497a37290bc944f1b619ca133faac73c9fd1a6c35f1f2afd8e84c17ddf37252b66f08650
+EBUILD golop-0.0.1.ebuild 633 BLAKE2B e6035e0bbb814381b1b5052f4fbf9d72fa8da900c4946f30a7d7c7ece2a4e28f6fa518a0db1dadcd23d66754341a40dd2a67949953f7e2a55e1ce0de068af4ef SHA512 78f05664cd421087a6aace536d3871e38913e2c2a3250debe98159aec145861a0c591553f3a98c7358a2fa4e4f290427f757e5e53ce06e0229a5459ead9d6245
+EBUILD golop-9999.ebuild 633 BLAKE2B 3872a51c5d532fd7ef4bdde7e08e875a0a6316cd9aff7af7b63867922bfd1fbf740c30e9d29663b367a5f704d4604394a6c2ebde75d308df1f49fe292f031057 SHA512 8eecca968e5dc993856c9d307ffdb58f72ac18880df63630f0c1ea6c8c015536263f569579280fb87f91cb0c2cc2793f07d635b66816f2468d5cf324877fbcd2
+MISC metadata.xml 579 BLAKE2B 0a87d4468fd6ce4306bc22ab8b66c93132beb922f0354843cf275cf75ebd9dbf413100cf26a1440aeae467b6544f6d2904df2849970e9c417d2109b41c9b43ad SHA512 8499152d39bd8922e7a3a23d87a574b44bc61ea32c85c835b1f443d933d8ebf2541802346e0a8cff69a565e781c4037662927537afff7d3d13636a607b4952fb
diff --git a/app-portage/golop/golop-0.0.1.ebuild b/app-portage/golop/golop-0.0.1.ebuild
new file mode 100644
index 000000000000..c244fad578e4
--- /dev/null
+++ b/app-portage/golop/golop-0.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+EGO_PN=github.com/klausman/golop
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~x86"
+ EGIT_COMMIT=v${PV}
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A pure Go re-implementation of genlop"
+HOMEPAGE="https://github.com/klausman/golop"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ dobin ${PN}
+
+ declare -a DOCS
+ DOCS+=( src/${EGO_PN}/README.md )
+ einstalldocs
+}
diff --git a/app-portage/golop/golop-9999.ebuild b/app-portage/golop/golop-9999.ebuild
new file mode 100644
index 000000000000..9e60869091a0
--- /dev/null
+++ b/app-portage/golop/golop-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+EGO_PN=github.com/klausman/golop
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~x86"
+ EGIT_COMMIT=v${PV}
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A pure Go re-implementation of genlop"
+HOMEPAGE="https://github.com/klausman/golop"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ dobin ${PN}
+
+ declare -a DOCS
+ DOCS+=( src/${EGO_PN}/README.md )
+ einstalldocs
+}
diff --git a/app-portage/golop/metadata.xml b/app-portage/golop/metadata.xml
new file mode 100644
index 000000000000..9cd9d4eefb09
--- /dev/null
+++ b/app-portage/golop/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>klausman@gentoo.org</email>
+ <name>Tobias Klausmann</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/klausman/golop/issues/</bugs-to>
+ <changelog>https://github.com/klausman/golop/commits/master</changelog>
+ <remote-id type="github">klausman/golop</remote-id>
+ </upstream>
+</pkgmetadata>