summaryrefslogtreecommitdiff
path: root/app-portage/golop/golop-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-portage/golop/golop-0.2.1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-portage/golop/golop-0.2.1.ebuild')
-rw-r--r--app-portage/golop/golop-0.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-portage/golop/golop-0.2.1.ebuild b/app-portage/golop/golop-0.2.1.ebuild
new file mode 100644
index 000000000000..fa33821ab317
--- /dev/null
+++ b/app-portage/golop/golop-0.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+EGO_PN=github.com/klausman/golop
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~x86"
+ EGIT_COMMIT=v${PV}
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A pure Go re-implementation of genlop"
+HOMEPAGE="https://github.com/klausman/golop"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ dobin ${PN}
+
+ declare -a DOCS
+ DOCS+=( src/${EGO_PN}/README.md )
+ einstalldocs
+}