summaryrefslogtreecommitdiff
path: root/app-portage/getuto/getuto-1.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-11 12:12:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-11 12:12:04 +0100
commit656415c9ea59def40c02f7dff6e0650186b509f3 (patch)
tree0fabd97ffdc789e947a3bf164c55c1bf183457de /app-portage/getuto/getuto-1.9.1.ebuild
parent8d839e24e6b6e9a28d945d1dc094e65e2b0ccc2d (diff)
gentoo auto-resync : 11:10:2023 - 12:12:04
Diffstat (limited to 'app-portage/getuto/getuto-1.9.1.ebuild')
-rw-r--r--app-portage/getuto/getuto-1.9.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-portage/getuto/getuto-1.9.1.ebuild b/app-portage/getuto/getuto-1.9.1.ebuild
new file mode 100644
index 000000000000..4778eb372c02
--- /dev/null
+++ b/app-portage/getuto/getuto-1.9.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Stand-alone gentoo install trust anchor generation tool"
+HOMEPAGE="https://github.com/projg2/getuto"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/projg2/getuto"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/projg2/getuto/archive/refs/tags/${P}.tar.gz
+ "
+ S=${WORKDIR}/${PN}-${P}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SRC_URI+=" test? ( https://mirror.bytemark.co.uk/gentoo/releases/amd64/binpackages/17.1/x86-64/virtual/libc/libc-1-r1-1.gpkg.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-crypt/gnupg
+ dev-libs/openssl
+ sec-keys/openpgp-keys-gentoo-release
+ sys-apps/gentoo-functions
+"
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ # Don't mangle test data
+ unpack ${P}.tar.gz
+ fi
+
+ if use test ; then
+ cp "${DISTDIR}"/libc-1-r1-1.gpkg.tar "${S}" || die
+ fi
+}
+
+src_install() {
+ dobin getuto
+}