summaryrefslogtreecommitdiff
path: root/app-portage/gentoopm/gentoopm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/gentoopm/gentoopm-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/gentoopm/gentoopm-9999.ebuild')
-rw-r--r--app-portage/gentoopm/gentoopm-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-portage/gentoopm/gentoopm-9999.ebuild b/app-portage/gentoopm/gentoopm-9999.ebuild
new file mode 100644
index 000000000000..96a9ef4eacfc
--- /dev/null
+++ b/app-portage/gentoopm/gentoopm-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+EGIT_REPO_URI="https://github.com/mgorny/gentoopm.git"
+inherit distutils-r1 git-r3
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="https://github.com/mgorny/gentoopm/"
+SRC_URI=""
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ || (
+ >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ >=sys-apps/paludis-3.0.0_pre20170219[python,${PYTHON_USEDEP}] )"
+PDEPEND="app-eselect/eselect-package-manager"
+
+python_test() {
+ esetup.py test
+}