summaryrefslogtreecommitdiff
path: root/app-portage/gentoopm/gentoopm-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-portage/gentoopm/gentoopm-0.4.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-portage/gentoopm/gentoopm-0.4.ebuild')
-rw-r--r--app-portage/gentoopm/gentoopm-0.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/gentoopm/gentoopm-0.4.ebuild b/app-portage/gentoopm/gentoopm-0.4.ebuild
new file mode 100644
index 000000000000..ac0d89b5c90a
--- /dev/null
+++ b/app-portage/gentoopm/gentoopm-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="https://github.com/mgorny/gentoopm/"
+SRC_URI="
+ https://github.com/mgorny/gentoopm/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ || (
+ >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
+PDEPEND="app-eselect/eselect-package-manager"
+
+distutils_enable_tests pytest
+
+python_test() {
+ if has_version ">=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]"; then
+ einfo "Testing against pkgcore ..."
+ PACKAGE_MANAGER=pkgcore epytest
+ fi
+ if has_version ">=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}]"; then
+ einfo "Testing against portage ..."
+ PACKAGE_MANAGER=portage epytest
+ fi
+}