summaryrefslogtreecommitdiff
path: root/app-portage/gentoolkit/gentoolkit-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /app-portage/gentoolkit/gentoolkit-9999.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'app-portage/gentoolkit/gentoolkit-9999.ebuild')
-rw-r--r--app-portage/gentoolkit/gentoolkit-9999.ebuild29
1 files changed, 9 insertions, 20 deletions
diff --git a/app-portage/gentoolkit/gentoolkit-9999.ebuild b/app-portage/gentoolkit/gentoolkit-9999.ebuild
index 53c6017a27bc..a05cb33f75d4 100644
--- a/app-portage/gentoolkit/gentoolkit-9999.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-9999.ebuild
@@ -7,18 +7,21 @@ DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
PYTHON_REQ_USE="xml(+),threads(+)"
-EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoolkit.git"
-inherit distutils-r1 git-r3
+inherit distutils-r1
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoolkit.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoolkit.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
DESCRIPTION="Collection of administration scripts for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
-SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
-KEYWORDS=""
DEPEND="
sys-apps/portage[${PYTHON_USEDEP}]"
@@ -42,25 +45,11 @@ python_prepare_all() {
fi
}
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-0.4.0"; then
- SHOW_GENTOOKIT_DEV_DEPRECATED_MSG=1
- fi
-}
-
pkg_postinst() {
# Create cache directory for revdep-rebuild
mkdir -p -m 0755 "${EROOT}"/var/cache
mkdir -p -m 0700 "${EROOT}"/var/cache/revdep-rebuild
- if [[ ${SHOW_GENTOOKIT_DEV_DEPRECATED_MSG} ]]; then
- elog "Starting with version 0.4.0, ebump, ekeyword and imlate are now"
- elog "part of the gentoolkit package."
- elog "The gentoolkit-dev package is now deprecated in favor of a single"
- elog "gentoolkit package. The remaining tools from gentoolkit-dev"
- elog "are now obsolete/unused with the git based tree."
- fi
-
# Only show the elog information on a new install
if [[ ! ${REPLACING_VERSIONS} ]]; then
elog