summaryrefslogtreecommitdiff
path: root/app-portage/gemato
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 14:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 14:01:09 +0000
commitdfa2037f41649c9775d690a3d01cfd5cabf4db71 (patch)
tree261884874fd25b6a9bff06b2e5f6106d091e3848 /app-portage/gemato
parent8ba94db1fe69019bb2d3b4f50fe9d1ccf3d94b3a (diff)
gentoo auto-resync : 15:02:2023 - 14:01:08
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/Manifest2
-rw-r--r--app-portage/gemato/gemato-19.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index e726c0e450e3..762092ca7406 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,4 +1,6 @@
DIST gemato-18.0.gh.tar.gz 85575 BLAKE2B a923c3d7731b70798d9baf7e9faf0884723bb5e15b4e24712ecd807b79e8ca7e1532f894cf6a3b675bd72419eac41f1481fcd34fb21c9989871141819b036fa2 SHA512 9491579c3d80f9b500da2a50aed173641d049293e37f11c3c06616ff49949cae16dfd274ae79dcacca4bb4c27baf30a5f3900f45fc3dfb2b9fb5da8139db63e3
+DIST gemato-19.0.gh.tar.gz 86174 BLAKE2B b13e17f3b4388df4c0b6980db8347d68f9e6cb2657cdbcb28a8466bcdebed9e986ecac2f0f88e549741eb62accd91ed48a8ee4a714a5decce68e1529174a4c90 SHA512 3a8dfc94770e4063da8f1bf42ffc4c261345af89edd223bbf64033a82c2e31cb3369b98467fdbe9bf911b76e5ef964b676b94803579525697ddc31be1b83017b
EBUILD gemato-18.0.ebuild 1106 BLAKE2B 66ae2706dac6276b75fdc1a102a01d0ddd1d496427956f34eb12e5b2dde1f39337318f0eec7882b059d3927244c46a610e26d6731662854d52a72681c3c6beaa SHA512 42b6bfad2c8acba3adbf0b47c7e36743f48aa44e635b6d97887a10dc4c7da34028cb7c6643ec03bf6522907309294a018803b3c0b5fef4d78d2985128a390d88
+EBUILD gemato-19.0.ebuild 1114 BLAKE2B c3d5d8f9b1a8034c7799c6f2d413738201cc70f455c101e1647679eb56da50400844277fa68baf58e3a4975d69ae6fbb6dd4bbdda544c55a389b68e40d112f28 SHA512 a8cf5b5443eadf1742877fbc9acf9c5a21b584227d9f8ee1066cf14491044768387859f914ea3bae352ad3a4c6d8d473965178549b5aa7ee9a7219d24b93b35a
EBUILD gemato-9999.ebuild 957 BLAKE2B 361e57ab1a563727eaaec872d9c427a9935ab5c2863996ae72869a8b6817824f81755ad7fb033ac782a71b09bfdb6c4e8e6290645b3d904647836b4705558ae3 SHA512 9383726e8c7be060b8537477733eb93cece38ed04b375455db0cb907d10647018f9a6021f6fd1e4388f66f6f4c6c80ff192c2e5b7f1e7132e63d99410ea39258
MISC metadata.xml 805 BLAKE2B 039ea9810f2c76d69bdfa5823994be4aa012746032a8c1e01aa7a11a05e4c4e0b278ff5633a519ad8e7398f3328480128c7d9d621dc7911d1ed1d827175c7dac SHA512 1fb3ec26e41b912cdd6ca289acadc50f2d73adf4e9cf9cae40c197ecfa10c19e17716e7153c9be82684ae35580d03ae296586b062f2d54641ab2738c338f1626
diff --git a/app-portage/gemato/gemato-19.0.ebuild b/app-portage/gemato/gemato-19.0.ebuild
new file mode 100644
index 000000000000..7e02cc9bba9d
--- /dev/null
+++ b/app-portage/gemato/gemato-19.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+SRC_URI="
+ https://github.com/projg2/gemato/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg pretty-log tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}