summaryrefslogtreecommitdiff
path: root/app-portage/gemato/gemato-14.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /app-portage/gemato/gemato-14.3.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'app-portage/gemato/gemato-14.3.ebuild')
-rw-r--r--app-portage/gemato/gemato-14.3.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/app-portage/gemato/gemato-14.3.ebuild b/app-portage/gemato/gemato-14.3.ebuild
index 5a53b2fe11d2..933874ddec7a 100644
--- a/app-portage/gemato/gemato-14.3.ebuild
+++ b/app-portage/gemato/gemato-14.3.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} pypy3 )
PYTHON_REQ_USE='threads(+)'
inherit distutils-r1
@@ -16,14 +16,10 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
-IUSE="+blake2 bzip2 +gpg lzma sha3 tools"
+IUSE="+gpg tools"
RDEPEND="
- blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_5} pypy{,3}) )
- bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
- gpg? ( app-crypt/gnupg )
- lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
- sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_5} pypy) )"
+ gpg? ( app-crypt/gnupg )"
distutils_enable_tests setup.py