summaryrefslogtreecommitdiff
path: root/app-portage/g-cpan/g-cpan-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-portage/g-cpan/g-cpan-9999.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/g-cpan/g-cpan-9999.ebuild')
-rw-r--r--app-portage/g-cpan/g-cpan-9999.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/app-portage/g-cpan/g-cpan-9999.ebuild b/app-portage/g-cpan/g-cpan-9999.ebuild
deleted file mode 100644
index 50536a4a795b..000000000000
--- a/app-portage/g-cpan/g-cpan-9999.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit perl-module
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/gentoo-perl/g-cpan.git"
- inherit git-r3
- SRC_URI=""
-else
- SRC_URI="https://github.com/gentoo-perl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-fi
-
-DESCRIPTION="Autogenerate and install ebuilds for CPAN modules"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
-
-LICENSE="|| ( Artistic GPL-2 )"
-SLOT="0"
-IUSE="test"
-
-COMMONDEPEND="
- dev-perl/Config-Tiny
- virtual/perl-File-Path
- virtual/perl-File-Spec
- dev-perl/Log-Agent
- virtual/perl-Memoize
- virtual/perl-IO
- dev-perl/Path-Tiny
- dev-perl/Shell-EnvImporter
- virtual/perl-Term-ANSIColor
- >=dev-perl/YAML-0.60
-"
-RDEPEND="${COMMONDEPEND}
- || (
- >=sys-apps/portage-2.0.0
- sys-apps/portage-mgorny
- )
-"
-DEPEND="${COMMONDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- test? ( >=virtual/perl-Test-Simple-0.940.0 )
-"
-
-src_install() {
- perl-module_src_install
- diropts -m0775 -o portage -g portage
- dodir "/var/tmp/g-cpan"
- dodir "/var/log/g-cpan"
- keepdir "/var/log/g-cpan"
-}
-
-pkg_postinst() {
- elog "If you want to use g-cpan as non root user you may wish to adjust"
- elog "the permissions on /var/tmp/g-cpan or add users to the portage group."
- elog "Please note that some CPAN packages need additional manual"
- elog "parameters or tweaking, due to bugs in their build systems."
-}