summaryrefslogtreecommitdiff
path: root/app-portage/fquery/fquery-0.2.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-portage/fquery/fquery-0.2.3-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-portage/fquery/fquery-0.2.3-r1.ebuild')
-rw-r--r--app-portage/fquery/fquery-0.2.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/fquery/fquery-0.2.3-r1.ebuild b/app-portage/fquery/fquery-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..ca7f17065233
--- /dev/null
+++ b/app-portage/fquery/fquery-0.2.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="Installed package query tool for Gentoo Linux"
+HOMEPAGE="https://hackage.haskell.org/package/fquery"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/hashtables:=
+ dev-haskell/parsec:=
+ dev-haskell/regex-compat:=
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_prepare() {
+ default
+
+ # Workaround for Cabal 2.2.0.1 running configure with
+ # ${S}/dist/build set as the current directory. This changes
+ # the script to prepend ${S}/ to the the paths. The script
+ # then uses the ${S} environment variable.
+ sed -e 's@\(Adelie/\)@${S}/\1@g' \
+ -i configure || die
+}