summaryrefslogtreecommitdiff
path: root/app-portage/flaggie/flaggie-0.2.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-portage/flaggie/flaggie-0.2.1-r2.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-portage/flaggie/flaggie-0.2.1-r2.ebuild')
-rw-r--r--app-portage/flaggie/flaggie-0.2.1-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/flaggie/flaggie-0.2.1-r2.ebuild b/app-portage/flaggie/flaggie-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..dc1e4ca5c0ae
--- /dev/null
+++ b/app-portage/flaggie/flaggie-0.2.1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="https://github.com/mgorny/flaggie/"
+SRC_URI="https://github.com/mgorny/flaggie/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~mips ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ newbashcomp contrib/bash-completion/${PN}.bash-completion ${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn "Please note that flaggie creates backups of your package.* files"
+ ewarn "before performing each change through appending a single '~'."
+ ewarn "If you'd like to keep your own backup of them, please use another"
+ ewarn "naming scheme (or even better some VCS)."
+ if ! has_version app-shells/gentoo-bashcomp; then
+ elog
+ elog "If you want to use bash-completion, you need to install:"
+ elog " app-shells/gentoo-bashcomp"
+ fi
+}