summaryrefslogtreecommitdiff
path: root/app-portage/esearch/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-portage/esearch/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-portage/esearch/files')
-rw-r--r--app-portage/esearch/files/1.3-Fix-python-3-compatability.patch34
-rw-r--r--app-portage/esearch/files/1.3-Fix-setup.py.patch28
-rw-r--r--app-portage/esearch/files/eupdatedb.cron32
3 files changed, 94 insertions, 0 deletions
diff --git a/app-portage/esearch/files/1.3-Fix-python-3-compatability.patch b/app-portage/esearch/files/1.3-Fix-python-3-compatability.patch
new file mode 100644
index 000000000000..36c9d2255b8c
--- /dev/null
+++ b/app-portage/esearch/files/1.3-Fix-python-3-compatability.patch
@@ -0,0 +1,34 @@
+From 3978f923ac814aef014cf412b63d11fd94f60692 Mon Sep 17 00:00:00 2001
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Wed, 8 May 2013 14:26:48 -0500
+Subject: [PATCH 1/2] Fix python 3 compatability with 'esearch -e' (Bug 469076)
+
+Thanks to zmedico for the patch.
+---
+ esearch/search.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/esearch/search.py b/esearch/search.py
+index f91f5b1..696a0f0 100755
+--- a/esearch/search.py
++++ b/esearch/search.py
+@@ -22,6 +22,7 @@ import re
+ try:
+ from portage.output import bold, red, green, darkgreen, turquoise, blue, nocolor
+ from portage import settings, pkgcmp, pkgsplit, portdb, best
++ from portage.util import cmp_sort_key
+ except ImportError:
+ print("Critical: portage imports failed!")
+ sys.exit(1)
+@@ -107,7 +108,7 @@ def searchEbuilds(path, portdir=True, searchdef="", repo_num="",
+ data['defebuild'] = (searchdef, pkgs[-1][3])
+ if not portdir:
+ config['found_in_overlay'] = True
+- pkgs.sort(mypkgcmp)
++ pkgs.sort(key=cmp_sort_key(mypkgcmp))
+ for pkg in pkgs:
+ rev = ""
+ if pkg[2] != "r0":
+--
+1.8.5.4
+
diff --git a/app-portage/esearch/files/1.3-Fix-setup.py.patch b/app-portage/esearch/files/1.3-Fix-setup.py.patch
new file mode 100644
index 000000000000..aad5d49f2f56
--- /dev/null
+++ b/app-portage/esearch/files/1.3-Fix-setup.py.patch
@@ -0,0 +1,28 @@
+From 94e77b115f5b14b7dfea50e4a7b77047e4b47263 Mon Sep 17 00:00:00 2001
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Tue, 18 Dec 2012 04:33:27 -0600
+Subject: [PATCH 1/3] Fix setup.py so that either VERSION or PVR will set the
+ version.
+
+This fixes the issue with egg-info always having a version number of
+9999. Fix is from Brian Dolbec courtesy of mirrorselect.
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 9d2addd..45a4c06 100755
+--- a/setup.py
++++ b/setup.py
+@@ -14,7 +14,7 @@ import io
+
+ sys.path.insert(0, os.path.join(os.path.dirname(__file__), 'pym'))
+
+-__version__ = os.getenv('VERSION', default='9999')
++__version__ = os.getenv('VERSION', default=os.getenv('PVR', default='9999'))
+
+ cwd = os.getcwd()
+
+--
+1.8.5.4
+
diff --git a/app-portage/esearch/files/eupdatedb.cron b/app-portage/esearch/files/eupdatedb.cron
new file mode 100644
index 000000000000..1cf802f7b05f
--- /dev/null
+++ b/app-portage/esearch/files/eupdatedb.cron
@@ -0,0 +1,32 @@
+#! /bin/bash
+
+# The eupdatedb script _needs_ to be installed with the filename 'eupdatedb'
+# because it does things based on basename $0.
+
+# Run some script
+
+SCRIPT="/usr/sbin/eupdatedb"
+SCRIPTPREOPTS="nice -n 19"
+SCRIPTOPTS="--quiet"
+PRECOMMAND=""
+POSTCOMMAND=""
+DATE="`date +%Y%m%d`"
+LOG="/var/log/`basename ${SCRIPT}`"
+
+${PRECOMMAND}
+
+# Start logging
+echo "--- Starting ${SCRIPT} for ${DATE} ---" >> ${LOG}
+
+if [ "`${SCRIPTPREOPTS} ${SCRIPT} ${SCRIPTOPTS}`" ]
+then
+ echo "${SCRIPT}: success." >> ${LOG}
+else
+ echo "ERROR: ${SCRIPT} failed." >> ${LOG}
+fi
+
+# Cleanup tasks
+${POSTCOMMAND}
+
+# End logging
+echo "--- Ending ${SCRIPT} for ${DATE} ---" >> ${LOG}