summaryrefslogtreecommitdiff
path: root/app-portage/elsw/elsw-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /app-portage/elsw/elsw-9999.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'app-portage/elsw/elsw-9999.ebuild')
-rw-r--r--app-portage/elsw/elsw-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/elsw/elsw-9999.ebuild b/app-portage/elsw/elsw-9999.ebuild
new file mode 100644
index 000000000000..521be8e3f793
--- /dev/null
+++ b/app-portage/elsw/elsw-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool providing a nice way to view the Portage world file"
+HOMEPAGE="https://gitlab.com/xgqt/python-elsw/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/xgqt/python-${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS=( README.md )