summaryrefslogtreecommitdiff
path: root/app-portage/elsw/elsw-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
commitafcb9236a72cf602364c28b9bde6648e4a7f1ca5 (patch)
tree9608aa2c881b2688207832334c938f0e38d5c71c /app-portage/elsw/elsw-1.0.0.ebuild
parentd3419aa304ff2564036398be5e8ed4bdeaeaa007 (diff)
gentoo auto-resync : 21:01:2024 - 02:09:25
Diffstat (limited to 'app-portage/elsw/elsw-1.0.0.ebuild')
-rw-r--r--app-portage/elsw/elsw-1.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/elsw/elsw-1.0.0.ebuild b/app-portage/elsw/elsw-1.0.0.ebuild
new file mode 100644
index 000000000000..f476f0d0e3b2
--- /dev/null
+++ b/app-portage/elsw/elsw-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool providing a nice way to view the Portage world file"
+HOMEPAGE="https://gitlab.com/xgqt/python-elsw/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/xgqt/python-${PN}.git"
+else
+ inherit pypi
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.md )