summaryrefslogtreecommitdiff
path: root/app-portage/elogv/elogv-0.7.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-05 17:54:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-05 17:54:48 +0100
commit8679463887b182c233b55d8112534d7d7dcde08b (patch)
tree3c45a448a6022fda1b09ac5ef94b5c02ddcc9b30 /app-portage/elogv/elogv-0.7.9.ebuild
parente8c80f80fd116cc679f261d8bc6ee6c9bfc3f0a0 (diff)
gentoo auto-resync : 05:10:2023 - 17:54:48
Diffstat (limited to 'app-portage/elogv/elogv-0.7.9.ebuild')
-rw-r--r--app-portage/elogv/elogv-0.7.9.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/app-portage/elogv/elogv-0.7.9.ebuild b/app-portage/elogv/elogv-0.7.9.ebuild
deleted file mode 100644
index ae233b4db343..000000000000
--- a/app-portage/elogv/elogv-0.7.9.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9,10} pypy3 )
-PYTHON_REQ_USE="ncurses"
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1
-
-DESCRIPTION="Curses based utility to parse the contents of elogs created by Portage"
-HOMEPAGE="https://gitweb.gentoo.org/proj/elogv.git/"
-SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ppc ~ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-RDEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-DOCS=( README )
-
-src_install() {
- distutils-r1_src_install
-
- # unset LINGUAS => install all languages
- # empty LINGUAS => install none
- local i
- if [[ -n "${LINGUAS+x}" ]] ; then
- for i in $(ls "${ED}"/usr/share/locale/) ; do
- if ! has ${i} ${LINGUAS} ; then
- rm -rf "${ED}"/usr/share/{locale,man}/${i}
- fi
- done
- fi
-}
-
-pkg_postinst() {
- elog "In order to use this software, you need to activate"
- elog "Portage's elog features. Required is"
- elog " PORTAGE_ELOG_SYSTEM=\"save\" "
- elog "and at least one out of "
- elog " PORTAGE_ELOG_CLASSES=\"warn error info log qa\""
- elog "More information on the elog system can be found"
- elog "in ${EPREFIX}/usr/share/portage/config/make.conf.example"
- elog
- elog "To operate properly this software needs the directory"
- elog "${PORT_LOGDIR:-${EPREFIX}/var/log/portage}/elog created, belonging to group portage."
- elog "To start the software as a user, add yourself to the portage"
- elog "group."
- elog
-}