summaryrefslogtreecommitdiff
path: root/app-portage/cpuid2cpuflags
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/cpuid2cpuflags
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/cpuid2cpuflags')
-rw-r--r--app-portage/cpuid2cpuflags/Manifest6
-rw-r--r--app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild39
-rw-r--r--app-portage/cpuid2cpuflags/cpuid2cpuflags-5.ebuild28
-rw-r--r--app-portage/cpuid2cpuflags/cpuid2cpuflags-9999.ebuild21
-rw-r--r--app-portage/cpuid2cpuflags/metadata.xml11
5 files changed, 105 insertions, 0 deletions
diff --git a/app-portage/cpuid2cpuflags/Manifest b/app-portage/cpuid2cpuflags/Manifest
new file mode 100644
index 000000000000..ac9883907db3
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/Manifest
@@ -0,0 +1,6 @@
+DIST cpuid2cpuflags-5.tar.bz2 72050 BLAKE2B e9b7022ae5b7d51c88b5e41d9d7af1175498cb5a1f32876bfb766f785060f501d07ba3a5c346961e742bbf7022121faf3d0d068ec711ee9ed4e67cbdcd72a58a SHA512 41dcd2b974f6bd96867dea15a3839a8d63a3ff600189107ab16a67b5bc77ef421acbedb83f3e3b16ec90ac900d187aa8c44baae6fbdb4988f3bf7caa2d0d19a2
+DIST cpuinfo2cpuflags-1.tar.gz 1429 BLAKE2B 5126e643e5e2ea0be2418068fbcfbbae1781a0e3ab7903d909d4a5a291cb2e5db132a7a6a5c6db12a757688efca0557e4331a91f64af4b7e47deca415fd05b34 SHA512 68a21cfdb0fc8c6eb5aad5c6702d50dd56c927b2010efea1651dbc6a9657654b770bc5a4055fb11e790066c2c63c9ea29c3e03d91057abe187e7029e6797aede
+EBUILD cpuid2cpuflags-1.ebuild 1058 BLAKE2B 2f84de424a39c3f163dffffb5acf0b919e1abd2375b961e6f1f281011157fe7fabcebcee4ba771abfb2fef9407fbf4c67a104aa3ec4de2bf1d81b91cbc6e272c SHA512 ca30faabee1bd898fc80f7207fe71d205d6ee6a09e1697f242bfafaca1071fb343ab58623d713b15202096f6e3e240dd83600ce0b695be546721037c77e9c850
+EBUILD cpuid2cpuflags-5.ebuild 927 BLAKE2B 453e5761cb2477c2e5dfadcc829cf284f5f078012f94f7c78a9c494817c2f892a01f54f921a3311c15c9235fd8338b5ea86b3e2a9c1cf4b176b151a9d0c55616 SHA512 e63150b6223b2658f3c34dc26527cd82c4c29e74278a569e4ae7039f9f90baab4e41f986d8ece1d989a8c1759f325fea9df763310ba5a0a59c80a25b3ae419f8
+EBUILD cpuid2cpuflags-9999.ebuild 410 BLAKE2B db323508784e37a7f4220c8d192460e854ab54bccfcebb40826821335de6834e97460dd4bc6dfbe11fc6d650171fb76a0a9196bb1bf6af81a08db35afda2e466 SHA512 02a38010f453641b73461f5afb980b7e1cb1817f3a688064d699827d698f94a3f27a65f7c0dddb7be287694cfe426bbfdd5ec03714d3b777a4975a38e5561b69
+MISC metadata.xml 343 BLAKE2B 29f607a891c673bbf997aa75bb445adfc43cffa35f63a30d1f2b06e4c5a7429ad503fae596c4c633b7e6680e26da674bd9f8aaea32a8a9bd8a3ac2c79a0a5667 SHA512 8ae8b8d61adaf555d1f59e50655e9e12f342e194ab8363f03a34390eed1455144acee39553b93306d9775b8c9fb119de52b8bb4d9284c71ddc39c3d3414a31dc
diff --git a/app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild b/app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild
new file mode 100644
index 000000000000..cc95afbc6f2f
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} pypy )
+
+inherit python-r1
+
+MY_PN=cpuinfo2cpuflags
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Script to guess CPU_FLAGS_X86 flags from /proc/cpuinfo"
+HOMEPAGE="https://github.com/mgorny/cpuid2cpuflags"
+SRC_URI="https://github.com/mgorny/cpuid2cpuflags/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=${PYTHON_DEPS}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ python_foreach_impl python_newscript "${MY_PN}-x86"{.py,}
+}
+
+pkg_postinst() {
+ if has_version 'sys-apps/portage' \
+ && ! has_version "sys-apps/portage[${PYTHON_USEDEP}]"
+ then
+ ewarn "Support for matching Python implementations should be enabled"
+ ewarn "on sys-apps/portage as well. Otherwise, cpuinfo2cpuflags won't"
+ ewarn "be able to figure out the correct repository location and will"
+ ewarn "require you to specify it explicitly."
+ fi
+}
diff --git a/app-portage/cpuid2cpuflags/cpuid2cpuflags-5.ebuild b/app-portage/cpuid2cpuflags/cpuid2cpuflags-5.ebuild
new file mode 100644
index 000000000000..cb1e96dd1c68
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/cpuid2cpuflags-5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tool to guess CPU_FLAGS_X86 flags for the host"
+HOMEPAGE="https://github.com/mgorny/cpuid2cpuflags"
+SRC_URI="https://github.com/mgorny/cpuid2cpuflags/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 x86 ~amd64-fbsd ~x86-fbsd ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ ${v%-r*} -lt 2 ]]; then
+ elog 'Please note that the output has changed in v2. The new format is suitable'
+ elog 'both for Portage and Paludis. To use it, e.g.:'
+ elog
+ elog ' $ echo "*/* $(cpuid2cpuflags)" > /etc/portage/package.use/00cpuflags'
+ elog
+ elog '(you may need to convert package.use into a directory if you want to use'
+ elog ' separate file as presented here)'
+ fi
+ done
+}
diff --git a/app-portage/cpuid2cpuflags/cpuid2cpuflags-9999.ebuild b/app-portage/cpuid2cpuflags/cpuid2cpuflags-9999.ebuild
new file mode 100644
index 000000000000..8e891b478ae5
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/cpuid2cpuflags-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/mgorny/cpuid2cpuflags"
+inherit autotools git-r3
+
+DESCRIPTION="Tool to guess CPU_FLAGS_X86 flags for the host"
+HOMEPAGE="https://github.com/mgorny/cpuid2cpuflags"
+SRC_URI=""
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
diff --git a/app-portage/cpuid2cpuflags/metadata.xml b/app-portage/cpuid2cpuflags/metadata.xml
new file mode 100644
index 000000000000..422aab7218c1
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mgorny/cpuid2cpuflags</remote-id>
+ </upstream>
+</pkgmetadata>