summaryrefslogtreecommitdiff
path: root/app-portage/conf-update/conf-update-1.0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-portage/conf-update/conf-update-1.0.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-portage/conf-update/conf-update-1.0.3-r1.ebuild')
-rw-r--r--app-portage/conf-update/conf-update-1.0.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/conf-update/conf-update-1.0.3-r1.ebuild b/app-portage/conf-update/conf-update-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..b599d25db4be
--- /dev/null
+++ b/app-portage/conf-update/conf-update-1.0.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="${PN} is a ncurses-based config management utility"
+HOMEPAGE="https://gitweb.gentoo.org/proj/conf-update.git/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="colordiff libressl"
+
+RDEPEND=">=dev-libs/glib-2.6
+ sys-libs/ncurses:0
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ colordiff? ( app-misc/colordiff )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/\$Rev:.*\\$/${PVR}/" "${S}"/"${PN}".h || die
+ if use colordiff ; then
+ sed -i -e "s/diff_tool=diff/diff_tool=colordiff/" ${PN}.conf \ die 'colordiff-sed failed'
+ fi
+ tc-export PKG_CONFIG
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}