summaryrefslogtreecommitdiff
path: root/app-pda/gnupod/gnupod-0.99.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-pda/gnupod/gnupod-0.99.8-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-pda/gnupod/gnupod-0.99.8-r1.ebuild')
-rw-r--r--app-pda/gnupod/gnupod-0.99.8-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-pda/gnupod/gnupod-0.99.8-r1.ebuild b/app-pda/gnupod/gnupod-0.99.8-r1.ebuild
new file mode 100644
index 000000000000..a9984189905e
--- /dev/null
+++ b/app-pda/gnupod/gnupod-0.99.8-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="A collection of Perl-scripts for iPod"
+HOMEPAGE="https://www.gnu.org/software/gnupod/"
+SRC_URI="http://blinkenlights.ch/gnupod-dist/stable/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="aac ffmpeg flac mp3 ogg"
+
+RDEPEND="dev-perl/TimeDate
+ dev-perl/XML-Parser
+ >=dev-perl/MP3-Info-1.01
+ dev-perl/Unicode-String
+ dev-perl/Digest-SHA1
+ dev-perl/libwww-perl
+ ffmpeg? ( virtual/ffmpeg )
+ flac? ( dev-perl/Audio-FLAC-Header
+ media-libs/flac
+ aac? ( >=media-libs/faac-1.24 )
+ mp3? ( media-sound/lame )
+ !aac? ( media-sound/lame ) )
+ ogg? ( dev-perl/Ogg-Vorbis-Header-PurePerl
+ media-sound/vorbis-tools
+ aac? ( >=media-libs/faac-1.24 )
+ mp3? ( media-sound/lame )
+ !aac? ( media-sound/lame ) )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ perl_set_version
+ sed -i -e "s:\$INC\[0\]/\$modi:${VENDOR_ARCH}/\$modi:g" \
+ tools/gnupod_install.pl || die
+
+ emake DESTDIR="${D}" install
+
+ dodoc CHANGES README* doc/gnupodrc.example doc/gnutunesdb.example
+ dohtml doc/gnupod.html
+}