summaryrefslogtreecommitdiff
path: root/app-office/unoconv/unoconv-0.9.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /app-office/unoconv/unoconv-0.9.0-r1.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'app-office/unoconv/unoconv-0.9.0-r1.ebuild')
-rw-r--r--app-office/unoconv/unoconv-0.9.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-office/unoconv/unoconv-0.9.0-r1.ebuild b/app-office/unoconv/unoconv-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..e6a52ebfc18b
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.9.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-single-r1
+
+DESCRIPTION="Convert between document formats supported by LibreOffice"
+HOMEPAGE="http://dag.wiee.rs/home-made/unoconv/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+PATCHES=( "${FILESDIR}/timeout.patch" )
+
+src_prepare() {
+ default
+ python_fix_shebang .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 doc-install install install-links DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog CHANGELOG.md README.adoc
+}