summaryrefslogtreecommitdiff
path: root/app-office/scribus/files/scribus-1.5.5-findhyphen-1.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /app-office/scribus/files/scribus-1.5.5-findhyphen-1.patch
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'app-office/scribus/files/scribus-1.5.5-findhyphen-1.patch')
-rw-r--r--app-office/scribus/files/scribus-1.5.5-findhyphen-1.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-office/scribus/files/scribus-1.5.5-findhyphen-1.patch b/app-office/scribus/files/scribus-1.5.5-findhyphen-1.patch
new file mode 100644
index 000000000000..98682d60f700
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.5.5-findhyphen-1.patch
@@ -0,0 +1,51 @@
+--- a/scribus/CMakeLists.txt 2019-10-02 00:25:01.194386515 +0200
++++ b/scribus/CMakeLists.txt 2019-10-02 00:26:23.584392213 +0200
+@@ -1069,7 +1069,9 @@
+ ${SCRIBUS_GMAGICK_SRC}
+ )
+
+-if(NOT HAVE_HYPHEN)
++if(HAVE_HYPHEN)
++ include_directories(${HYPHEN_INCLUDE_DIR})
++else()
+ include_directories(third_party/hyphen)
+ set(SCRIBUS_SOURCES
+ ${SCRIBUS_SOURCES}
+@@ -1180,13 +1182,6 @@
+
+ endif()
+
+-if(HAVE_HYPHEN)
+- target_link_libraries(${EXE_NAME}
+- ${HYPHEN_LIBRARY}
+- )
+-endif()
+-
+-
+ if(GESTURE_FRAME_PREVIEW)
+ message(STATUS "Enable gesture frame preview [experimental]")
+ set(GESTURE_FRAME_PREVIEW_SOURCES pageitempreview.cpp)
+@@ -1234,6 +1229,12 @@
+ )
+ endif ()
+
++if(HAVE_HYPHEN)
++ target_link_libraries(${EXE_NAME}
++ ${HYPHEN_LIBRARY}
++ )
++endif()
++
+ if(WIN32)
+ set_target_properties(${EXE_NAME}
+ PROPERTIES
+--- a/scribus/hyphenator.h 2019-07-31 00:35:05.000000000 +0200
++++ b/scribus/hyphenator.h 2019-10-02 00:00:42.497285638 +0200
+@@ -13,7 +13,7 @@
+ #include <QSet>
+
+ #include "scribusapi.h"
+-#include "third_party/hyphen/hyphen.h"
++#include <hyphen.h>
+
+ class ScribusDoc;
+ class ScribusMainWindow;