summaryrefslogtreecommitdiff
path: root/app-office/plan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/plan
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/plan')
-rw-r--r--app-office/plan/Manifest4
-rw-r--r--app-office/plan/metadata.xml8
-rw-r--r--app-office/plan/plan-1.10.ebuild72
3 files changed, 84 insertions, 0 deletions
diff --git a/app-office/plan/Manifest b/app-office/plan/Manifest
new file mode 100644
index 000000000000..3409dd9532c5
--- /dev/null
+++ b/app-office/plan/Manifest
@@ -0,0 +1,4 @@
+DIST plan-1.10-gentoo.tar.xz 5976 BLAKE2B 598c92a750fc0a305d7f51211f9e42eae36644de1a83175fcb86c8c30450b8fc1e7d2eabbaced62779d80b557f7f725c97395bc744171952970faa3543abba2f SHA512 60fcfe1fec1d7911a155d6737e6a808ea897ce7c4207bd2f4e95f57b1d154d8d594c6f5ecc8a959cc0d7f47f1415f86797e0c4053873775decfc048bc16048a3
+DIST plan-1.10.tar.gz 460150 BLAKE2B a44c79537ff6aae8fa5c65c8b6514f0f37d1417522f4e54823ad14cf6306bb88223377de13f22c365516e2861fa561902e31245c9729786f425140bed30b320d SHA512 fde17ef17f25412cbe69427364f4130564f46a940859066c25d837d14eca6920752b843211192a6c1cdc83be05de9ac57c88424ca555928b67eb219fa8564fe8
+EBUILD plan-1.10.ebuild 1442 BLAKE2B ad7a1c27524b2b4e7693e1201a8f0d8148bd270bd578e3a41273c493b165e10d189fcf07f6391de1d7c668e206de6e38a9bcfd9f78c057af25b3082e458cf15f SHA512 4c377cc88dba84ceedb674bdc62c6eb90610f14726e9538aee4a2a4297ea226a6a77942082ead1e992d0247d00d77ed5235a70fd96999946b98d659ed2085fd8
+MISC metadata.xml 258 BLAKE2B 18104e5bf54213c7d7302cc72c3ec47d0c322f2fd397dde15b5ee29db433961329fd2b22c379d19125d7f5ded7dcc376d3afb9ce77426d9615022bde50078649 SHA512 a4886b16e304b05a448e28681a38ec68fcdd7828029444fd9c01aab0fdda8d9540cd0d829da2e9f22b38b33d10e85bf111c8e45b49966c32b267c90704adec40
diff --git a/app-office/plan/metadata.xml b/app-office/plan/metadata.xml
new file mode 100644
index 000000000000..389bcb80364f
--- /dev/null
+++ b/app-office/plan/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ Plan is a Motif based schedule planner.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-office/plan/plan-1.10.ebuild b/app-office/plan/plan-1.10.ebuild
new file mode 100644
index 000000000000..642152f24661
--- /dev/null
+++ b/app-office/plan/plan-1.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Motif based schedule planner"
+HOMEPAGE="https://www.bitrot.de/plan.html"
+SRC_URI="ftp://ftp.fu-berlin.de/unix/X11/apps/plan/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.tar.xz"
+
+LICENSE="GPL-2+" #448646
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ x11-libs/libXpm
+ >=x11-libs/motif-2.3:0
+"
+RDEPEND="${DEPEND}"
+
+QA_PRESTRIPPED="
+/usr/bin/netplan
+/usr/bin/plan
+"
+src_prepare() {
+ epatch "${WORKDIR}"/${P}-patches/*.patch
+}
+
+src_compile() {
+ pushd src
+ emake CC=$(tc-getCC) SHARE=/usr/share/plan linux
+ popd
+}
+
+src_install() {
+ pushd src
+ emake \
+ DESTDIR="${D}" \
+ SHARE=/usr/share/plan \
+ install
+ keepdir /usr/share/plan/netplan.dir
+ popd
+
+ dodoc HISTORY README
+
+ pushd misc
+ doman netplan.1 plan.1 plan.4
+ insinto /usr/share/${PN}/misc
+ doins netplan.boot BlackWhite Monochrome plan.fti Plan.xpm plan.xpm
+ exeinto /usr/share/${PN}/misc
+ doexe Killpland cvs vsc msschedule2plan plan2vcs
+ popd
+
+ pushd web
+ insinto /usr/share/${PN}/web
+ doins help.html bottom.html cgi-lib.pl common.pl holiday_webplan rtsban.jpg
+ exeinto /usr/share/${PN}/web
+ doexe *.cgi
+ popd
+}
+
+pkg_postinst() {
+ elog
+ elog " Check /usr/share/${PN}/holiday for examples to set your"
+ elog " ~/.holiday according to your country."
+ elog
+ elog " WebPlan ${PV} can be found in /usr/share/${PN}/web."
+ elog
+}