summaryrefslogtreecommitdiff
path: root/app-office/orage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /app-office/orage
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'app-office/orage')
-rw-r--r--app-office/orage/Manifest3
-rw-r--r--app-office/orage/metadata.xml8
-rw-r--r--app-office/orage/orage-4.18.0.ebuild60
3 files changed, 71 insertions, 0 deletions
diff --git a/app-office/orage/Manifest b/app-office/orage/Manifest
new file mode 100644
index 000000000000..c54de2a5ff24
--- /dev/null
+++ b/app-office/orage/Manifest
@@ -0,0 +1,3 @@
+DIST orage-4.18.0.tar.bz2 1418645 BLAKE2B 533f55d4a6e69c0458fb01a8b3fd6a20f30b409ddd1d2eb65f00c321daa441d7e99e154ee4558160fc3e387e2ddb45a2ee0c37e6814a74f40e724fd748cd2fa5 SHA512 7760219f64ac3e2ba6d73541a626a0c9411b93268c007f2af5d8080a3a3c0b2a08e00dd96b7794b688aa83c567150c02033b9ba46bf38cd71d3d890e8d1e45ad
+EBUILD orage-4.18.0.ebuild 1050 BLAKE2B 74e4370a7ba38b8bb5426123b39563b5ebaaf892f9fb68a481a824d4e397ca93610e7cee2b99e4ab982f087c74583041a69b2b5b14ce159141051996f8704525 SHA512 99d6eee7f78ae9c50f00d37a3b2c9c995f36272c58955e1f071512cd66dd72f65e0abfe414f86292cd2ac52a074902d85af73310de9bffb327447d68ab0057c3
+MISC metadata.xml 241 BLAKE2B 19a1f7371ba9451232b7795e806499d1de2aba44dc9864bf1c8c72f6074af18387f6091c891f84c402c70e52f8502bc7a9a937828d63991402d2f0d17b247782 SHA512 97a8057b496da7d18b75e0cec2f5de16f7f16187776c3d7134ade6b0be2539c5f0e8de7ce43c2a4fc342ca9c3dd83a74c194a506ad28221c260dfa8a4eadb1e8
diff --git a/app-office/orage/metadata.xml b/app-office/orage/metadata.xml
new file mode 100644
index 000000000000..dce6704738a4
--- /dev/null
+++ b/app-office/orage/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-office/orage/orage-4.18.0.ebuild b/app-office/orage/orage-4.18.0.ebuild
new file mode 100644
index 000000000000..f9d75fd99c9a
--- /dev/null
+++ b/app-office/orage/orage-4.18.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A calendar application for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/apps/orage/start
+ https://gitlab.xfce.org/apps/orage/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.58.0
+ >=dev-libs/libical-3.0.16:=
+ >=x11-libs/gtk+-3.24.0:3=
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ libnotify? ( >=x11-libs/libnotify-0.7.0:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}