summaryrefslogtreecommitdiff
path: root/app-office/orage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/orage
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/orage')
-rw-r--r--app-office/orage/Manifest3
-rw-r--r--app-office/orage/metadata.xml12
-rw-r--r--app-office/orage/orage-4.12.1-r1.ebuild63
3 files changed, 78 insertions, 0 deletions
diff --git a/app-office/orage/Manifest b/app-office/orage/Manifest
new file mode 100644
index 000000000000..33c4a7253bc3
--- /dev/null
+++ b/app-office/orage/Manifest
@@ -0,0 +1,3 @@
+DIST orage-4.12.1.tar.bz2 2590788 BLAKE2B 0f00b5704e11923c2ceaac81f0956457402a90f65709c165c98b6942745ea3adee176691555a18548ead258951693187e1b3ce9a718abb3b13c2a1c2a4754e7e SHA512 3fec0201171140586cdc9bcf151450a7086515e18b5815afe4fe4c4726ba554c50582b0479e52985b330140c51b7233ef81f678f986f848afbeee74c66b2d196
+EBUILD orage-4.12.1-r1.ebuild 1551 BLAKE2B 7b68711f09b5263f72248ea59a11616f61c9e188fb3105ca7c3ffa54f6e88abdc5d6e235175cba3f8130d9ae4431d5a2a286da77c90fd574cde7f0b44ddce12a SHA512 83e6b2110405c82c3c72389563f9180e26646c9d91b8d82383cf9fed91acc90ca005658c00be8283bcdc5d2dcd5a4ab93eb31182defda79b82d553e8ef3ea773
+MISC metadata.xml 355 BLAKE2B 4ddbf38a80be81b7e131d7c616dfb88dff1e900952c17c4cc4dd26711e720351177d92d8225825dd57354399ecdb8b7bccd18f883fcd927846e8614dd4ac4a99 SHA512 a5d3f875ac31caa10ca77ce8eb38449b3007094d1b9d7d307bd15ee29644c09530d44ac6a4953e10adfa3bd45b6a3fe44dbbb3b80ab7d0c8572c48523ef287eb
diff --git a/app-office/orage/metadata.xml b/app-office/orage/metadata.xml
new file mode 100644
index 000000000000..71878d4da925
--- /dev/null
+++ b/app-office/orage/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <use>
+ <flag name='clock-panel-plugin'>Build the clock plugin for the XFCE
+ panel</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-office/orage/orage-4.12.1-r1.ebuild b/app-office/orage/orage-4.12.1-r1.ebuild
new file mode 100644
index 000000000000..afbcd0af7e23
--- /dev/null
+++ b/app-office/orage/orage-4.12.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A time managing application (and panel plug-in) for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/apps/orage/"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="berkdb +clock-panel-plugin dbus libnotify"
+
+RDEPEND=">=dev-libs/libical-0.48:=
+ dev-libs/popt:=
+ >=x11-libs/gtk+-2.10:2=
+ berkdb? ( >=sys-libs/db-4:= )
+ clock-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ dbus? ( >=dev-libs/dbus-glib-0.100:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable clock-panel-plugin libxfce4panel)
+ $(use_enable dbus)
+ $(use_enable libnotify)
+ $(use_with berkdb bdb4)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_preinst() {
+ # Replacing directory by symlink is unreliable
+ if [[ -L ${EROOT}/usr/share/orage/doc/C ]]; then
+ rm -f "${EROOT}/usr/share/orage/doc/C" || die
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}