summaryrefslogtreecommitdiff
path: root/app-office/orage/orage-4.18.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /app-office/orage/orage-4.18.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'app-office/orage/orage-4.18.0.ebuild')
-rw-r--r--app-office/orage/orage-4.18.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-office/orage/orage-4.18.0.ebuild b/app-office/orage/orage-4.18.0.ebuild
new file mode 100644
index 000000000000..f9d75fd99c9a
--- /dev/null
+++ b/app-office/orage/orage-4.18.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A calendar application for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/apps/orage/start
+ https://gitlab.xfce.org/apps/orage/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.58.0
+ >=dev-libs/libical-3.0.16:=
+ >=x11-libs/gtk+-3.24.0:3=
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ libnotify? ( >=x11-libs/libnotify-0.7.0:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}