summaryrefslogtreecommitdiff
path: root/app-office/onlyoffice-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-16 18:25:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-16 18:25:06 +0000
commit7972abc05090180dcc09d2b16af4020ce1cd1841 (patch)
tree3e6e1c7ca86ab7d4e8dc45009f67403fc489ade9 /app-office/onlyoffice-bin
parente4ad5901ca8464ae513bd315a1c0349c2bd0986c (diff)
gentoo auto-resync : 16:03:2023 - 18:25:06
Diffstat (limited to 'app-office/onlyoffice-bin')
-rw-r--r--app-office/onlyoffice-bin/Manifest3
-rw-r--r--app-office/onlyoffice-bin/metadata.xml15
-rw-r--r--app-office/onlyoffice-bin/onlyoffice-bin-7.3.3.ebuild78
3 files changed, 96 insertions, 0 deletions
diff --git a/app-office/onlyoffice-bin/Manifest b/app-office/onlyoffice-bin/Manifest
new file mode 100644
index 000000000000..053416774911
--- /dev/null
+++ b/app-office/onlyoffice-bin/Manifest
@@ -0,0 +1,3 @@
+DIST onlyoffice-bin-7.3.3_amd64.deb 194296022 BLAKE2B 3f687cd4cfffb742ea078d08b575f3893765f4a82003a52e8645917e3e5f164ed7d547458ee58621dc3cb021bf5bbcc7fa9e88ae5130afac9662c186b256ff1f SHA512 fd3e9a48e488ef8fb8be01f3b1bfeeb87fe1a25d2a81e1716146557cfdf8a3822d36f5a66f43c6cb596d8e072bc1d3407f8320b092d9a1f0e9a54bb9f7920fa8
+EBUILD onlyoffice-bin-7.3.3.ebuild 1743 BLAKE2B 14c1c312b16998fa9a58188bb8ae36ec05cf7888a1d46b75243359f91fdb6139d86aa9e010418d61e0b3854e07d2d3cbb250981d3128a1cc0981e6f60f10dfe7 SHA512 cf801afcbcfa7fb4033f0cd4c394144a20fe90a30a6187841f26f89a48474ddf6f46d9a86553606204413eb9f9c0416a46c26227587649cae8ddf5e7a691e885
+MISC metadata.xml 445 BLAKE2B 482136e28fb31d39958018bafa81c01a75af85884180cc2638d6420df9ac59f24c4e473982e7725eddc64886e812131c553345f5eec892b056b8519be2a86f22 SHA512 b93d2df227637839fec3ecd45402a77f52e547758a528300660184319f684330f0ee6ca33feb249b828401b6d657799f8c6f5dc8af94af758abbc5989fc4a4de
diff --git a/app-office/onlyoffice-bin/metadata.xml b/app-office/onlyoffice-bin/metadata.xml
new file mode 100644
index 000000000000..d3cc03317573
--- /dev/null
+++ b/app-office/onlyoffice-bin/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ONLYOFFICE/DesktopEditors</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-office/onlyoffice-bin/onlyoffice-bin-7.3.3.ebuild b/app-office/onlyoffice-bin/onlyoffice-bin-7.3.3.ebuild
new file mode 100644
index 000000000000..e88bb3d1c410
--- /dev/null
+++ b/app-office/onlyoffice-bin/onlyoffice-bin-7.3.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+MY_P="ONLYOFFICE-DesktopEditors-"${PV}""
+
+DESCRIPTION="Onlyoffice is an office productivity suite (binary version)"
+HOMEPAGE="https://www.onlyoffice.com/"
+SRC_URI="
+ amd64? (
+ https://github.com/ONLYOFFICE/DesktopEditors/releases/download/v"${PV}"/onlyoffice-desktopeditors_amd64.deb
+ -> "${P}"_amd64.deb
+ )
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror strip test"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/wayland
+ dev-qt/qtgui:5[eglfs]
+ dev-qt/qtdeclarative:5
+ dev-qt/qtwayland:5
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/harfbuzz
+ media-libs/libglvnd
+ media-libs/libpulse
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="*"
+
+src_install() {
+ domenu usr/share/applications/onlyoffice-desktopeditors.desktop
+ for size in {16,24,32,48,64,128,256}; do
+ newicon -s "${size}" opt/onlyoffice/desktopeditors/asc-de-"${size}".png onlyoffice-desktopeditors.png
+ done
+
+ dobin usr/bin/desktopeditors usr/bin/onlyoffice-desktopeditors
+ doins -r opt
+ fperms +x /opt/onlyoffice/desktopeditors/{DesktopEditors,editors_helper,converter/x2t}
+}