summaryrefslogtreecommitdiff
path: root/app-office/moneyguru
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /app-office/moneyguru
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'app-office/moneyguru')
-rw-r--r--app-office/moneyguru/Manifest3
-rw-r--r--app-office/moneyguru/metadata.xml11
-rw-r--r--app-office/moneyguru/moneyguru-2.13.1.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/app-office/moneyguru/Manifest b/app-office/moneyguru/Manifest
new file mode 100644
index 000000000000..885d0799da8d
--- /dev/null
+++ b/app-office/moneyguru/Manifest
@@ -0,0 +1,3 @@
+DIST moneyguru-2.13.1.tar.gz 1665892 BLAKE2B 969286130c5336f4c41ccf0ee3cbfe55a13560f753e137ff5370184c5aff3e038995c79ad48620a5653552406ea6fb56d356a209cd36774751db4f8e3777354c SHA512 9544a2fe17d0c1d4a6f1ee6c52c79e66ca76da6a6ac35067f1961fe2b44a8efe20173ee5932a91adeeebcb0a522b544df11ad388cb4c453a0641060d75f2a17c
+EBUILD moneyguru-2.13.1.ebuild 933 BLAKE2B 5d0942c18322103220ead22dd78cef0e2aae4faf9f436a58407b50473515de6830e144650063823acf657b0622cdd63453173147201264cc57648ac75ba09eed SHA512 b447088bc3edb64c0672e887cf3e3c4b05ff48d4b80faa45720bcae57e8a8c82b6fcaa0c2deae82edeedfa8708438510d426e53d80c43491586e2258fdf60c58
+MISC metadata.xml 327 BLAKE2B f5321e18ece590533473467467f84d9ad63c202d2249c469f88d9896ef635625e3ee48f3497d81fe9e418e8819fb06b4609684279223978a366332163b25c1c9 SHA512 b0d34d5ba1be127bc8ffbe8f712b8f469333517bc288d471e365106876ed7db0a411c96520b606fefdb273495d1f75cdd4c6caa131fba2aec2483ff39e099fb4
diff --git a/app-office/moneyguru/metadata.xml b/app-office/moneyguru/metadata.xml
new file mode 100644
index 000000000000..951b70bfa8e2
--- /dev/null
+++ b/app-office/moneyguru/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vdurpas@gentoo.org</email>
+ <name>Virgil Dupras</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hsoft/moneyguru</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-office/moneyguru/moneyguru-2.13.1.ebuild b/app-office/moneyguru/moneyguru-2.13.1.ebuild
new file mode 100644
index 000000000000..ffe8516e22b5
--- /dev/null
+++ b/app-office/moneyguru/moneyguru-2.13.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-single-r1
+
+DESCRIPTION="Future-aware personal finances management"
+HOMEPAGE="https://hardcoded.net/moneyguru"
+SRC_URI="https://download.hardcoded.net/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets,printsupport]
+ dev-qt/qttranslations"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cunit
+ )"
+
+_emake() {
+ emake CFLAGS="\$(DEFAULT_CFLAGS) ${CFLAGS}" \
+ SHEBANG="${PYTHON}" \
+ DESTDIR="${ED}" \
+ PREFIX=/usr \
+ $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake install
+}
+
+src_test() {
+ emake -C ccore CFLAGS="\$(DEFAULT_CFLAGS) ${CFLAGS}" tests
+ pytest -vv core || die "Tests failed with ${EPYTHON}"
+}