summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/libreoffice-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:17:25 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:17:25 +0100
commit62f82c107c3904ac6917ece47301d2999c7dd90e (patch)
tree48ddfc2291e77d0e3ad80f6d7c5f403d84ae8414 /app-office/libreoffice/libreoffice-9999.ebuild
parent7fe80ac8764ccbf354f82029a6bce4f96dbb8d5d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/libreoffice/libreoffice-9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index cc4c2bc8ce11..46abef27e981 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -64,7 +64,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="bluetooth +branding coinmp +cups dbus debug eds firebird googledrive
-gstreamer +gtk gtk2 kde libressl mysql odk pdfimport postgres test vlc
+gstreamer +gtk gtk2 kde mysql odk pdfimport postgres test vlc
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -79,7 +79,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
LICENSE="|| ( LGPL-3 MPL-1.1 )"
SLOT="0"
[[ ${MY_PV} == *9999* ]] || \
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
COMMON_DEPEND="${PYTHON_DEPS}
app-arch/unzip
@@ -114,10 +114,10 @@ COMMON_DEPEND="${PYTHON_DEPS}
dev-libs/libgpg-error
>=dev-libs/liborcus-0.13.3
dev-libs/librevenge
+ dev-libs/libxml2
+ dev-libs/libxslt
dev-libs/nspr
dev-libs/nss
- !libressl? ( >=dev-libs/openssl-1.0.0d:0 )
- libressl? ( dev-libs/libressl )
>=dev-libs/redland-1.0.16
>=dev-libs/xmlsec-1.2.24[nss]
media-gfx/graphite2
@@ -136,6 +136,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
net-misc/curl
net-nds/openldap
sci-mathematics/lpsolve
+ sys-libs/zlib:=
virtual/glu
virtual/jpeg:0
virtual/opengl
@@ -163,10 +164,12 @@ COMMON_DEPEND="${PYTHON_DEPS}
gnome-base/dconf
media-libs/mesa[egl]
x11-libs/gtk+:3
+ x11-libs/pango
)
gtk2? (
x11-libs/gdk-pixbuf
>=x11-libs/gtk+-2.24:2
+ x11-libs/pango
)
kde? (
dev-qt/qtcore:5
@@ -211,10 +214,7 @@ fi
# after everything upstream is under gbuild
# as dmake execute tests right away
DEPEND="${COMMON_DEPEND}
- !<sys-devel/make-3.82
>=dev-libs/libatomic_ops-7.2d
- >=dev-libs/libxml2-2.7.8
- dev-libs/libxslt
dev-perl/Archive-Zip
>=dev-util/cppunit-1.14.0
>=dev-util/gperf-3
@@ -225,7 +225,6 @@ DEPEND="${COMMON_DEPEND}
sys-devel/flex
sys-devel/gettext
sys-devel/ucpp
- sys-libs/zlib
virtual/pkgconfig
x11-base/xorg-proto
x11-libs/libXt
@@ -262,6 +261,7 @@ _check_reqs() {
else
CHECKREQS_DISK_BUILD="6G"
fi
+ check-reqs_$1
}
pkg_pretend() {
@@ -274,10 +274,7 @@ pkg_pretend() {
ewarn "See also: https://wiki.documentfoundation.org/ReleaseNotes/5.3#Base"
fi
- if [[ ${MERGE_TYPE} != binary ]]; then
- _check_reqs
- check-reqs_pkg_pretend
- fi
+ [[ ${MERGE_TYPE} != binary ]] && _check_reqs pkg_pretend
}
pkg_setup() {
@@ -285,10 +282,7 @@ pkg_setup() {
python-single-r1_pkg_setup
xdg_environment_reset
- if [[ ${MERGE_TYPE} != binary ]]; then
- _check_reqs
- check-reqs_pkg_setup
- fi
+ [[ ${MERGE_TYPE} != binary ]] && _check_reqs pkg_setup
}
src_unpack() {
@@ -405,6 +399,7 @@ src_configure() {
--disable-fetch-external
--disable-gstreamer-0-10
--disable-online-update
+ --disable-openssl
--disable-pdfium
--disable-report-builder
--with-alloc=system
@@ -417,6 +412,7 @@ src_configure() {
--with-lang=""
--with-parallelism=$(makeopts_jobs)
--with-system-ucpp
+ --with-tls=nss
--with-vendor="Gentoo Foundation"
--with-x
--without-fonts