summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
commitf1bc537f089cc8477a9a18db597cb349e1b00e91 (patch)
treec48eb730c43e5f35729fabbe5cb4bfbe4a1bc794 /app-office/libreoffice/files
parentcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (diff)
gentoo resync : 16.06.2018
Diffstat (limited to 'app-office/libreoffice/files')
-rw-r--r--app-office/libreoffice/files/libreoffice-5.4.7.2-glm-0.9.9.patch82
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch34
2 files changed, 116 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-5.4.7.2-glm-0.9.9.patch b/app-office/libreoffice/files/libreoffice-5.4.7.2-glm-0.9.9.patch
new file mode 100644
index 000000000000..28982d90c369
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.4.7.2-glm-0.9.9.patch
@@ -0,0 +1,82 @@
+From 7984347b9a2fce74cdce0c1c5b27f6e2b55a2f49 Mon Sep 17 00:00:00 2001
+From: Rene Engelhard <rene@debian.org>
+Date: Sun, 28 Jan 2018 19:48:25 +0100
+Subject: fix build with glm 0.9.9
+
+In file included from /usr/include/glm/gtx/norm.hpp:18:0,
+ from /data/rene/git/LibreOffice/master/vcl/inc/opengl/VertexUti
+ls.hxx:16,
+ from /data/rene/git/LibreOffice/master/vcl/inc/opengl/LineRende
+rUtils.hxx:14,
+ from /data/rene/git/LibreOffice/master/vcl/opengl/LineRenderUti
+ls.cxx:11:
+/usr/include/glm/gtx/quaternion.hpp:23:3: error: #error "GLM: GLM_GTX_quaternion
+ is an experimental extension and may change in the future. Use #define GLM_ENABLE_EXPERIMENTAL before including it, if you really want to use it."
+ # error "GLM: GLM_GTX_quaternion is an experimental extension and may change in the future. Use #define GLM_ENABLE_EXPERIMENTAL before including it, if you really want to use it."
+ ^~~~~
+
+so just define it.
+
+Change-Id: I981bfb5fd944f32a3774b3f9b183989773bf235f
+Reviewed-on: https://gerrit.libreoffice.org/48799
+Tested-by: Jenkins <ci@libreoffice.org>
+Tested-by: Rene Engelhard <rene@debian.org>
+Reviewed-by: Rene Engelhard <rene@debian.org>
+---
+ chart2/Library_chartcore.mk | 6 ++++++
+ chart2/Library_chartopengl.mk | 6 ++++++
+ vcl/Library_vcl.mk | 6 ++++++
+ 3 files changed, 18 insertions(+)
+
+diff --git a/chart2/Library_chartcore.mk b/chart2/Library_chartcore.mk
+index f785d09..08455f9 100644
+--- a/chart2/Library_chartcore.mk
++++ b/chart2/Library_chartcore.mk
+@@ -23,6 +23,12 @@ $(eval $(call gb_Library_add_defs,chartcore,\
+ -DOOO_DLLIMPLEMENTATION_CHARTVIEW \
+ ))
+
++ifeq ($(SYSTEM_GLM),TRUE)
++$(eval $(call gb_Library_add_defs,chartcore,\
++ -DGLM_ENABLE_EXPERIMENTAL \
++))
++endif
++
+ $(eval $(call gb_Library_set_precompiled_header,chartcore,$(SRCDIR)/chart2/inc/pch/precompiled_chartcore))
+
+ $(eval $(call gb_Library_use_externals,chartcore,\
+diff --git a/chart2/Library_chartopengl.mk b/chart2/Library_chartopengl.mk
+index f999f94..8b5a22c 100644
+--- a/chart2/Library_chartopengl.mk
++++ b/chart2/Library_chartopengl.mk
+@@ -54,5 +54,11 @@ $(eval $(call gb_Library_add_exception_objects,chartopengl,\
+ chart2/source/view/main/DummyXShape \
+ chart2/source/view/main/OpenGLRender \
+ ))
++
++ifeq ($(SYSTEM_GLM),TRUE)
++$(eval $(call gb_Library_add_defs,chartopengl,\
++ -DGLM_ENABLE_EXPERIMENTAL \
++))
++endif
+
+ # vim: set noet sw=4 ts=4:
+diff --git a/vcl/Library_vcl.mk b/vcl/Library_vcl.mk
+index 699d6ab..a2caa8e 100644
+--- a/vcl/Library_vcl.mk
++++ b/vcl/Library_vcl.mk
+@@ -49,6 +49,12 @@ $(eval $(call gb_Library_add_defs,vcl,\
+ -DENABLE_MERGELIBS=$(if $(MERGELIBS),1,0) \
+ ))
+
++ifeq ($(SYSTEM_GLM),TRUE)
++$(eval $(call gb_Library_add_defs,vcl,\
++ -DGLM_ENABLE_EXPERIMENTAL \
++))
++endif
++
+ $(eval $(call gb_Library_use_sdk_api,vcl))
+
+ $(eval $(call gb_Library_use_custom_headers,vcl,\
+--
+cgit v1.1
diff --git a/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch b/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch
new file mode 100644
index 000000000000..1430fdf1a346
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch
@@ -0,0 +1,34 @@
+From 5f1bf6598b5725ad1e50ae9f7ec7524cc8a834fa Mon Sep 17 00:00:00 2001
+From: Louis Sautier <sautier.louis@gmail.com>
+Date: Sun, 10 Jun 2018 12:25:18 +0200
+Subject: Fix build with GLM 0.9.9.0, tdf#118070
+
+One of the test files was forgotten in 953c4add8fd76d88f49a81ae4c21a1fdcc007e57
+
+Change-Id: I0315433c688ff7edb2ba599bbef203cac9de3022
+Reviewed-on: https://gerrit.libreoffice.org/55554
+Reviewed-by: Rene Engelhard <rene@debian.org>
+Tested-by: Rene Engelhard <rene@debian.org>
+---
+ vcl/Executable_icontest.mk | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/vcl/Executable_icontest.mk b/vcl/Executable_icontest.mk
+index ce16330..8c917b7 100644
+--- a/vcl/Executable_icontest.mk
++++ b/vcl/Executable_icontest.mk
+@@ -19,6 +19,12 @@ $(eval $(call gb_Executable_use_externals,icontest,\
+ ))
+ endif
+
++ifeq ($(SYSTEM_GLM),TRUE)
++$(eval $(call gb_Executable_add_defs,icontest,\
++ -DGLM_ENABLE_EXPERIMENTAL \
++))
++endif
++
+ $(eval $(call gb_Executable_use_api,icontest,\
+ offapi \
+ udkapi \
+--
+cgit v1.1