summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /app-office/libreoffice/files
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'app-office/libreoffice/files')
-rw-r--r--app-office/libreoffice/files/libreoffice-7.1.6.2-KF5-fix-double-buffer-graphics.patch310
-rw-r--r--app-office/libreoffice/files/libreoffice-7.2.2.2-makefile-gengal.patch90
2 files changed, 90 insertions, 310 deletions
diff --git a/app-office/libreoffice/files/libreoffice-7.1.6.2-KF5-fix-double-buffer-graphics.patch b/app-office/libreoffice/files/libreoffice-7.1.6.2-KF5-fix-double-buffer-graphics.patch
deleted file mode 100644
index 36ed138f2a31..000000000000
--- a/app-office/libreoffice/files/libreoffice-7.1.6.2-KF5-fix-double-buffer-graphics.patch
+++ /dev/null
@@ -1,310 +0,0 @@
-From ec23228a3a2fc4e8868f7f04b838313be59ad719 Mon Sep 17 00:00:00 2001
-From: Jan-Marek Glogowski <glogow@fbihome.de>
-Date: Sun, 11 Apr 2021 17:40:26 +0200
-Subject: tdf#143796 Qt5/KF5 fix double-buffer graphics
-
-This is a squashed commit for:
-
-"Qt5/KF5 get rid of unneeded own grahics handling"
-"tdf#143334 Qt5 don't reset buffer on style change"
-"tdf#144008 Qt5/Kf5 create frames in the GUI thread"
-
-commit 963f252cd1ea9c268a6ced68a3454b10cbee1a89
-commit ec77a2ed0283cb3446f6e352fc329afd3dfb785c
-commit 923b30aa27ceb377d6a540c012000e89ce5db31e
-
-The first commit exposed the same problem to kf5, the 2nd patch is
-the real fix and the 3rd partly a regression for kf5 from the 1st
-commit but also an additional bugfix for qt5.
-
-Change-Id: I84b8dd106a35a5c2fda08a525f657b0b733a5cb7
-Reviewed-on: https://gerrit.libreoffice.org/c/core/+/121795
-Tested-by: Jenkins
-Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
-Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
-Reviewed-by: Adolfo Jayme Barrientos <fitojb@ubuntu.com>
----
- vcl/inc/qt5/Qt5Frame.hxx | 8 +-------
- vcl/inc/qt5/Qt5Instance.hxx | 1 +
- vcl/qt5/Qt5Frame.cxx | 34 ++++++++++++----------------------
- vcl/qt5/Qt5Instance.cxx | 18 +++++++++++++++---
- vcl/unx/kf5/KF5SalFrame.cxx | 24 ------------------------
- vcl/unx/kf5/KF5SalFrame.hxx | 6 ------
- vcl/unx/kf5/KF5SalInstance.cxx | 16 +++++++++++++---
- vcl/unx/kf5/KF5SalInstance.hxx | 1 +
- 8 files changed, 43 insertions(+), 65 deletions(-)
-
-diff --git a/vcl/inc/qt5/Qt5Frame.hxx b/vcl/inc/qt5/Qt5Frame.hxx
-index 54a721e03730..9b6e3811c3bb 100644
---- a/vcl/inc/qt5/Qt5Frame.hxx
-+++ b/vcl/inc/qt5/Qt5Frame.hxx
-@@ -77,17 +77,12 @@ class VCLPLUG_QT5_PUBLIC Qt5Frame : public QObject, public SalFrame
- std::unique_ptr<QImage> m_pQImage;
- std::unique_ptr<Qt5Graphics> m_pQt5Graphics;
- UniqueCairoSurface m_pSurface;
-- std::unique_ptr<Qt5SvpGraphics> m_pOurSvpGraphics;
-- // in base class, this ptr is the same as m_pOurSvpGraphic
-- // in derived class, it can point to a derivative
-- // of Qt5SvpGraphics (which the derived class then owns)
-- Qt5SvpGraphics* m_pSvpGraphics;
-+ std::unique_ptr<Qt5SvpGraphics> m_pSvpGraphics;
- DamageHandler m_aDamageHandler;
- QRegion m_aRegion;
- bool m_bNullRegion;
-
- bool m_bGraphicsInUse;
-- bool m_bGraphicsInvalid;
- SalFrameStyleFlags m_nStyle;
- Qt5Frame* m_pParent;
- PointerStyle m_ePointerStyle;
-@@ -144,7 +139,6 @@ public:
- void Damage(sal_Int32 nExtentsX, sal_Int32 nExtentsY, sal_Int32 nExtentsWidth,
- sal_Int32 nExtentsHeight) const;
-
-- void InitQt5SvpGraphics(Qt5SvpGraphics* pQt5SvpGraphics);
- virtual SalGraphics* AcquireGraphics() override;
- virtual void ReleaseGraphics(SalGraphics* pGraphics) override;
-
-diff --git a/vcl/inc/qt5/Qt5Instance.hxx b/vcl/inc/qt5/Qt5Instance.hxx
-index d73a59de51c1..a2372e58f8c9 100644
---- a/vcl/inc/qt5/Qt5Instance.hxx
-+++ b/vcl/inc/qt5/Qt5Instance.hxx
-@@ -82,6 +82,7 @@ protected:
- virtual Qt5FilePicker*
- createPicker(css::uno::Reference<css::uno::XComponentContext> const& context,
- QFileDialog::FileMode);
-+ bool useCairo() const { return m_bUseCairo; }
-
- public:
- explicit Qt5Instance(std::unique_ptr<QApplication>& pQApp, bool bUseCairo = false);
-diff --git a/vcl/qt5/Qt5Frame.cxx b/vcl/qt5/Qt5Frame.cxx
-index b398e9a5cf3b..d39d1729c812 100644
---- a/vcl/qt5/Qt5Frame.cxx
-+++ b/vcl/qt5/Qt5Frame.cxx
-@@ -104,10 +104,8 @@ sal_Int32 screenNumber(const QScreen* pScreen)
- Qt5Frame::Qt5Frame(Qt5Frame* pParent, SalFrameStyleFlags nStyle, bool bUseCairo)
- : m_pTopLevel(nullptr)
- , m_bUseCairo(bUseCairo)
-- , m_pSvpGraphics(nullptr)
- , m_bNullRegion(true)
- , m_bGraphicsInUse(false)
-- , m_bGraphicsInvalid(false)
- , m_ePointerStyle(PointerStyle::Arrow)
- , m_pDragSource(nullptr)
- , m_pDropTarget(nullptr)
-@@ -288,17 +286,6 @@ void Qt5Frame::Damage(sal_Int32 nExtentsX, sal_Int32 nExtentsY, sal_Int32 nExten
- 1 / devicePixelRatioF()));
- }
-
--void Qt5Frame::InitQt5SvpGraphics(Qt5SvpGraphics* pQt5SvpGraphics)
--{
-- QSize aSize = m_pQWidget->size() * devicePixelRatioF();
-- m_pSvpGraphics = pQt5SvpGraphics;
-- m_pSurface.reset(
-- cairo_image_surface_create(CAIRO_FORMAT_ARGB32, aSize.width(), aSize.height()));
-- m_pSvpGraphics->setSurface(m_pSurface.get(), basegfx::B2IVector(aSize.width(), aSize.height()));
-- cairo_surface_set_user_data(m_pSurface.get(), Qt5SvpGraphics::getDamageKey(), &m_aDamageHandler,
-- nullptr);
--}
--
- SalGraphics* Qt5Frame::AcquireGraphics()
- {
- if (m_bGraphicsInUse)
-@@ -308,24 +295,28 @@ SalGraphics* Qt5Frame::AcquireGraphics()
-
- if (m_bUseCairo)
- {
-- if (!m_pOurSvpGraphics || m_bGraphicsInvalid)
-+ if (!m_pSvpGraphics)
- {
-- m_pOurSvpGraphics.reset(new Qt5SvpGraphics(this));
-- InitQt5SvpGraphics(m_pOurSvpGraphics.get());
-- m_bGraphicsInvalid = false;
-+ QSize aSize = m_pQWidget->size() * devicePixelRatioF();
-+ m_pSvpGraphics.reset(new Qt5SvpGraphics(this));
-+ m_pSurface.reset(
-+ cairo_image_surface_create(CAIRO_FORMAT_ARGB32, aSize.width(), aSize.height()));
-+ m_pSvpGraphics->setSurface(m_pSurface.get(),
-+ basegfx::B2IVector(aSize.width(), aSize.height()));
-+ cairo_surface_set_user_data(m_pSurface.get(), Qt5SvpGraphics::getDamageKey(),
-+ &m_aDamageHandler, nullptr);
- }
-- return m_pOurSvpGraphics.get();
-+ return m_pSvpGraphics.get();
- }
- else
- {
-- if (!m_pQt5Graphics || m_bGraphicsInvalid)
-+ if (!m_pQt5Graphics)
- {
- m_pQt5Graphics.reset(new Qt5Graphics(this));
- m_pQImage.reset(
- new QImage(m_pQWidget->size() * devicePixelRatioF(), Qt5_DefaultFormat32));
- m_pQImage->fill(Qt::transparent);
- m_pQt5Graphics->ChangeQImage(m_pQImage.get());
-- m_bGraphicsInvalid = false;
- }
- return m_pQt5Graphics.get();
- }
-@@ -335,7 +326,7 @@ void Qt5Frame::ReleaseGraphics(SalGraphics* pSalGraph)
- {
- (void)pSalGraph;
- if (m_bUseCairo)
-- assert(pSalGraph == m_pOurSvpGraphics.get());
-+ assert(pSalGraph == m_pSvpGraphics.get());
- else
- assert(pSalGraph == m_pQt5Graphics.get());
- m_bGraphicsInUse = false;
-@@ -1145,7 +1136,6 @@ void Qt5Frame::UpdateSettings(AllSettings& rSettings)
- style.SetShadowColor(toColor(pal.color(QPalette::Disabled, QPalette::WindowText)));
- style.SetDarkShadowColor(toColor(pal.color(QPalette::Inactive, QPalette::WindowText)));
-
-- m_bGraphicsInvalid = true;
- rSettings.SetStyleSettings(style);
- }
-
-diff --git a/vcl/qt5/Qt5Instance.cxx b/vcl/qt5/Qt5Instance.cxx
-index ca1f914dd707..bceae35e9016 100644
---- a/vcl/qt5/Qt5Instance.cxx
-+++ b/vcl/qt5/Qt5Instance.cxx
-@@ -252,13 +252,21 @@ void Qt5Instance::deleteObjectLater(QObject* pObject) { pObject->deleteLater();
-
- SalFrame* Qt5Instance::CreateChildFrame(SystemParentData* /*pParent*/, SalFrameStyleFlags nStyle)
- {
-- return new Qt5Frame(nullptr, nStyle, m_bUseCairo);
-+ SalFrame* pRet(nullptr);
-+ RunInMainThread([&, this]() { pRet = new Qt5Frame(nullptr, nStyle, useCairo()); });
-+ assert(pRet);
-+ return pRet;
- }
-
- SalFrame* Qt5Instance::CreateFrame(SalFrame* pParent, SalFrameStyleFlags nStyle)
- {
- assert(!pParent || dynamic_cast<Qt5Frame*>(pParent));
-- return new Qt5Frame(static_cast<Qt5Frame*>(pParent), nStyle, m_bUseCairo);
-+
-+ SalFrame* pRet(nullptr);
-+ RunInMainThread(
-+ [&, this]() { pRet = new Qt5Frame(static_cast<Qt5Frame*>(pParent), nStyle, useCairo()); });
-+ assert(pRet);
-+ return pRet;
- }
-
- void Qt5Instance::DestroyFrame(SalFrame* pFrame)
-@@ -273,7 +281,11 @@ void Qt5Instance::DestroyFrame(SalFrame* pFrame)
- SalObject* Qt5Instance::CreateObject(SalFrame* pParent, SystemWindowData*, bool bShow)
- {
- assert(!pParent || dynamic_cast<Qt5Frame*>(pParent));
-- return new Qt5Object(static_cast<Qt5Frame*>(pParent), bShow);
-+
-+ SalObject* pRet(nullptr);
-+ RunInMainThread([&]() { pRet = new Qt5Object(static_cast<Qt5Frame*>(pParent), bShow); });
-+ assert(pRet);
-+ return pRet;
- }
-
- void Qt5Instance::DestroyObject(SalObject* pObject)
-diff --git a/vcl/unx/kf5/KF5SalFrame.cxx b/vcl/unx/kf5/KF5SalFrame.cxx
-index 1aa0b9008de7..8f14594586d2 100644
---- a/vcl/unx/kf5/KF5SalFrame.cxx
-+++ b/vcl/unx/kf5/KF5SalFrame.cxx
-@@ -45,7 +45,6 @@
-
- KF5SalFrame::KF5SalFrame(KF5SalFrame* pParent, SalFrameStyleFlags nState, bool bUseCairo)
- : Qt5Frame(pParent, nState, bUseCairo)
-- , m_bGraphicsInUse(false)
- {
- }
-
-@@ -162,27 +161,4 @@ void KF5SalFrame::UpdateSettings(AllSettings& rSettings)
- rSettings.SetStyleSettings(style);
- }
-
--SalGraphics* KF5SalFrame::AcquireGraphics()
--{
-- if (m_bGraphicsInUse)
-- return nullptr;
--
-- m_bGraphicsInUse = true;
--
-- if (!m_pKF5Graphics)
-- {
-- m_pKF5Graphics.reset(new Qt5SvpGraphics(this));
-- Qt5Frame::InitQt5SvpGraphics(m_pKF5Graphics.get());
-- }
--
-- return m_pKF5Graphics.get();
--}
--
--void KF5SalFrame::ReleaseGraphics(SalGraphics* pSalGraph)
--{
-- (void)pSalGraph;
-- assert(pSalGraph == m_pKF5Graphics.get());
-- m_bGraphicsInUse = false;
--}
--
- /* vim:set shiftwidth=4 softtabstop=4 expandtab: */
-diff --git a/vcl/unx/kf5/KF5SalFrame.hxx b/vcl/unx/kf5/KF5SalFrame.hxx
-index f757535c2f35..d0fdd91978e6 100644
---- a/vcl/unx/kf5/KF5SalFrame.hxx
-+++ b/vcl/unx/kf5/KF5SalFrame.hxx
-@@ -28,15 +28,9 @@ class QWidget;
-
- class KF5SalFrame : public Qt5Frame
- {
--private:
-- std::unique_ptr<Qt5SvpGraphics> m_pKF5Graphics;
-- bool m_bGraphicsInUse;
--
- public:
- KF5SalFrame(KF5SalFrame* pParent, SalFrameStyleFlags nStyle, bool bUseCairo);
-
-- virtual SalGraphics* AcquireGraphics() override;
-- virtual void ReleaseGraphics(SalGraphics* pGraphics) override;
- virtual void UpdateSettings(AllSettings& rSettings) override;
- };
-
-diff --git a/vcl/unx/kf5/KF5SalInstance.cxx b/vcl/unx/kf5/KF5SalInstance.cxx
-index 5b95ff8df572..d9d7747fe647 100644
---- a/vcl/unx/kf5/KF5SalInstance.cxx
-+++ b/vcl/unx/kf5/KF5SalInstance.cxx
-@@ -40,11 +40,21 @@ KF5SalInstance::KF5SalInstance(std::unique_ptr<QApplication>& pQApp)
- pSVData->maAppData.mxToolkitName = OUString("kf5");
- }
-
--SalFrame* KF5SalInstance::CreateFrame(SalFrame* pParent, SalFrameStyleFlags nState)
-+SalFrame* KF5SalInstance::CreateChildFrame(SystemParentData* /*pParent*/, SalFrameStyleFlags nStyle)
- {
- SalFrame* pRet(nullptr);
-- RunInMainThread([&pRet, pParent, nState]() {
-- pRet = new KF5SalFrame(static_cast<KF5SalFrame*>(pParent), nState, true);
-+ RunInMainThread([&, this]() { pRet = new KF5SalFrame(nullptr, nStyle, useCairo()); });
-+ assert(pRet);
-+ return pRet;
-+}
-+
-+SalFrame* KF5SalInstance::CreateFrame(SalFrame* pParent, SalFrameStyleFlags nStyle)
-+{
-+ assert(!pParent || dynamic_cast<KF5SalFrame*>(pParent));
-+
-+ SalFrame* pRet(nullptr);
-+ RunInMainThread([&, this]() {
-+ pRet = new KF5SalFrame(static_cast<KF5SalFrame*>(pParent), nStyle, useCairo());
- });
- assert(pRet);
- return pRet;
-diff --git a/vcl/unx/kf5/KF5SalInstance.hxx b/vcl/unx/kf5/KF5SalInstance.hxx
-index 5dd306da5231..b951df59ab33 100644
---- a/vcl/unx/kf5/KF5SalInstance.hxx
-+++ b/vcl/unx/kf5/KF5SalInstance.hxx
-@@ -28,6 +28,7 @@ class KF5SalInstance final : public Qt5Instance
- QFileDialog::FileMode) override;
-
- SalFrame* CreateFrame(SalFrame* pParent, SalFrameStyleFlags nStyle) override;
-+ SalFrame* CreateChildFrame(SystemParentData* pParent, SalFrameStyleFlags nStyle) override;
-
- public:
- explicit KF5SalInstance(std::unique_ptr<QApplication>& pQApp);
---
-cgit v1.2.1
-
diff --git a/app-office/libreoffice/files/libreoffice-7.2.2.2-makefile-gengal.patch b/app-office/libreoffice/files/libreoffice-7.2.2.2-makefile-gengal.patch
new file mode 100644
index 000000000000..5fd0179ccb05
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-7.2.2.2-makefile-gengal.patch
@@ -0,0 +1,90 @@
+https://github.com/LibreOffice/core/commit/0e7d4d99beda181f4e22725e4b8295d25489696f
+https://bugs.gentoo.org/821265
+
+From 0e7d4d99beda181f4e22725e4b8295d25489696f Mon Sep 17 00:00:00 2001
+From: Stephan Bergmann <sbergman@redhat.com>
+Date: Sun, 22 Aug 2021 11:26:38 +0200
+Subject: [PATCH] gengal needs Library_localedata_en now
+
+Whatever caused that requirement, but a from-scratch build of e.g.
+Gallery_backgrounds failed for me (with a follow-on SIGABRT after
+"framework/source/services/desktop.cxx:176: Desktop::~Desktop(): Who forgot to
+dispose this service?") because it failed to load
+instdir/program/../program/liblocaledata_en.so at
+
+> #1 0x00007fffda0b9671 in i18npool::LocaleDataImpl::getFunctionSymbol(com::sun::star::lang::Locale const&, char const*) (this=0x159b630, rLocale=..., pFunction=0x7fffda136ed8 "getAllFormats0") at i18npool/source/localedata/localedata.cxx:1460
+> #2 0x00007fffda0b6a93 in i18npool::LocaleDataImpl::FormatSection::getFunc(i18npool::LocaleDataImpl&, com::sun::star::lang::Locale const&, char const*) (this=0x7fffffffc840, rLocaleData=..., rL=..., pName=0x7fffda136ed8 "getAllFormats0") at i18npool/source/localedata/localedata.cxx:857
+> #3 0x00007fffda0b6b5c in i18npool::LocaleDataImpl::getAllFormats(com::sun::star::lang::Locale const&) (this=0x159b630, rLocale=...) at i18npool/source/localedata/localedata.cxx:865
+> #4 0x00007fffda0d4815 in NumberFormatCodeMapper::getFormats(com::sun::star::lang::Locale const&) (this=0x1594fa0, rLocale=...) at i18npool/source/numberformatcode/numberformatcode.cxx:150
+> #5 0x00007fffda0d4155 in NumberFormatCodeMapper::getAllFormatCode(short, com::sun::star::lang::Locale const&) (this=0x1594fa0, formatUsage=8, rLocale=...) at i18npool/source/numberformatcode/numberformatcode.cxx:92
+> #6 0x00007ffff572a824 in LocaleDataWrapper::loadCurrencyFormats() (this=0x159b3f0) at unotools/source/i18n/localedatawrapper.cxx:544
+> #7 0x00007ffff572777e in LocaleDataWrapper::loadData() (this=0x159b3f0) at unotools/source/i18n/localedatawrapper.cxx:131
+> #8 0x00007ffff57271b4 in LocaleDataWrapper::LocaleDataWrapper(LanguageTag const&, std::__debug::vector<rtl::OUString, std::allocator<rtl::OUString> > const&) (this=0x159b3f0, rLanguageTag=..., rOverrideDateAcceptancePatterns=std::__debug::vector of length 0, capacity 0) at unotools/source/i18n/localedatawrapper.cxx:80
+> #9 0x00007ffff5766fd6 in SvtSysLocale_Impl::SvtSysLocale_Impl() (this=0x158a4e0) at unotools/source/misc/syslocale.cxx:67
+> #10 0x00007ffff5768ad7 in std::construct_at<SvtSysLocale_Impl>(SvtSysLocale_Impl*) (__location=0x158a4e0) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/stl_construct.h:97
+> #11 0x00007ffff5768b1c in std::allocator_traits<std::allocator<SvtSysLocale_Impl> >::construct<SvtSysLocale_Impl>(std::allocator<SvtSysLocale_Impl>&, SvtSysLocale_Impl*) (__a=..., __p=0x158a4e0) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/alloc_traits.h:514
+> #12 0x00007ffff57688c2 in std::_Sp_counted_ptr_inplace<SvtSysLocale_Impl, std::allocator<SvtSysLocale_Impl>, (__gnu_cxx::_Lock_policy)2>::_Sp_counted_ptr_inplace<>(std::allocator<SvtSysLocale_Impl>) (this=0x158a4d0, __a=...) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/shared_ptr_base.h:519
+> #13 0x00007ffff576860a in std::__shared_count<(__gnu_cxx::_Lock_policy)2>::__shared_count<SvtSysLocale_Impl, std::allocator<SvtSysLocale_Impl>>(SvtSysLocale_Impl*&, std::_Sp_alloc_shared_tag<std::allocator<SvtSysLocale_Impl> >) (this=0x7fffffffd0a8, __p=@0x7fffffffd0a0: 0x0, __a=...) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/shared_ptr_base.h:650
+> #14 0x00007ffff57684c6 in std::__shared_ptr<SvtSysLocale_Impl, (__gnu_cxx::_Lock_policy)2>::__shared_ptr<std::allocator<SvtSysLocale_Impl>>(std::_Sp_alloc_shared_tag<std::allocator<SvtSysLocale_Impl> >) (this=0x7fffffffd0a0, __tag=...) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/shared_ptr_base.h:1342
+> #15 0x00007ffff576838d in std::shared_ptr<SvtSysLocale_Impl>::shared_ptr<std::allocator<SvtSysLocale_Impl>>(std::_Sp_alloc_shared_tag<std::allocator<SvtSysLocale_Impl> >) (this=0x7fffffffd0a0, __tag=...) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/shared_ptr.h:409
+> #16 0x00007ffff5768164 in std::allocate_shared<SvtSysLocale_Impl, std::allocator<SvtSysLocale_Impl>>(std::allocator<SvtSysLocale_Impl> const&) (__a=...) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/shared_ptr.h:863
+> #17 0x00007ffff5767dfc in std::make_shared<SvtSysLocale_Impl>() () at ~/gcc/trunk/inst/include/c++/12.0.0/bits/shared_ptr.h:879
+> #18 0x00007ffff5767583 in SvtSysLocale::SvtSysLocale() (this=0x7fffffffd120) at unotools/source/misc/syslocale.cxx:122
+> #19 0x00007ffff015148f in FwkResId(TranslateId) (aId=...) at framework/source/fwe/classes/fwkresid.cxx:22
+> #20 0x00007ffff025f333 in framework::Desktop::constructorInit() (this=0x1588850) at framework/source/services/desktop.cxx:106
+> #21 0x00007ffff0265c1c in (anonymous namespace)::createDesktop(com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&) (context=...) at framework/source/services/desktop.cxx:1764
+> #22 0x00007ffff0265ce5 in framework::getDesktop(com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&) (context=...) at framework/source/services/desktop.cxx:1773
+> #23 0x00007ffff0265d9e in com_sun_star_comp_framework_Desktop_get_implementation(com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&) (context=0x522200) at framework/source/services/desktop.cxx:1782
+> #24 0x00007ffff5a5d864 in std::__invoke_impl<com::sun::star::uno::XInterface*, com::sun::star::uno::XInterface* (*&)(com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&), com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&>(std::__invoke_other, com::sun::star::uno::XInterface* (*&)(com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&), com::sun::star::uno::XComponentContext*&&, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&) (__f=@0x54bb58: 0x7ffff0265d5f <com_sun_star_comp_framework_Desktop_get_implementation(com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&)>) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/invoke.h:61
+> #25 0x00007ffff5a551f4 in std::__invoke_r<com::sun::star::uno::XInterface*, com::sun::star::uno::XInterface* (*&)(com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&), com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&>(com::sun::star::uno::XInterface* (*&)(com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&), com::sun::star::uno::XComponentContext*&&, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&) (__fn=@0x54bb58: 0x7ffff0265d5f <com_sun_star_comp_framework_Desktop_get_implementation(com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&)>) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/invoke.h:114
+> #26 0x00007ffff5a4d254 in std::_Function_handler<com::sun::star::uno::XInterface* (com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&), com::sun::star::uno::XInterface* (*)(com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&)>::_M_invoke(std::_Any_data const&, com::sun::star::uno::XComponentContext*&&, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&) (__functor=..., __args#0=@0x7fffffffd4f0: 0x522200, __args#1=...) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/std_function.h:291
+> #27 0x00007ffff5a3f913 in std::function<com::sun::star::uno::XInterface* (com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&)>::operator()(com::sun::star::uno::XComponentContext*, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&) const (this=0x54bb58, __args#0=0x522200, __args#1=...) at ~/gcc/trunk/inst/include/c++/12.0.0/bits/std_function.h:568
+> #28 0x00007ffff5a2a396 in cppuhelper::ServiceManager::Data::Implementation::doCreateInstance(com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&) (this=0x54baa0, context=...) at cppuhelper/source/servicemanager.cxx:704
+> #29 0x00007ffff5a2a12a in cppuhelper::ServiceManager::Data::Implementation::createInstance(com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&, bool) (this=0x54baa0, context=..., singletonRequest=false) at cppuhelper/source/servicemanager.cxx:672
+> #30 0x00007ffff5a2d02d in cppuhelper::ServiceManager::createInstanceWithContext(rtl::OUString const&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&) (this=0x523450, aServiceSpecifier=..., Context=...) at cppuhelper/source/servicemanager.cxx:1003
+> #31 0x00007ffff6cd9922 in com::sun::star::frame::Desktop::create(com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&) (the_context=...) at workdir/UnoApiHeadersTarget/offapi/normal/com/sun/star/frame/Desktop.hpp:38
+> #32 0x00007ffff6cd8c07 in SfxApplication::Initialize_Impl() (this=0x1588150) at sfx2/source/appl/appinit.cxx:182
+> #33 0x00007ffff6cb776a in SfxApplication::GetOrCreate() () at sfx2/source/appl/app.cxx:122
+> #34 0x0000000000405ecf in (anonymous namespace)::GalApp::Main() (this=0x4204e0 <vclmain::createApplication()::aGalApp>) at svx/source/gengal/gengal.cxx:254
+> #35 0x00007ffff2dd6777 in ImplSVMain() () at vcl/source/app/svmain.cxx:199
+> #36 0x00007ffff2dd6898 in SVMain() () at vcl/source/app/svmain.cxx:231
+> #37 0x0000000000410f1f in sal_main() () at vcl/source/salmain/salmain.cxx:34
+> #38 0x0000000000410efa in main(int, char**) (argc=10, argv=0x7fffffffded8) at vcl/source/salmain/salmain.cxx:29
+
+This fix should remove the need for the cross-build--only fix
+0e142fa01972ad28182ca54b855d0ecae0d5c83b "cross-toolset: gengal now needs
+localedata_en", which it reverts.
+
+Change-Id: If71b7249c19619a83911c7624e3d99077decba31
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/120837
+Tested-by: Jenkins
+Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
+---
+ RepositoryExternal.mk | 1 +
+ solenv/gbuild/extensions/pre_BuildTools.mk | 1 -
+ 2 files changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/RepositoryExternal.mk b/RepositoryExternal.mk
+index 6e732c94793b2..15cfbfde3d4ac 100644
+--- a/RepositoryExternal.mk
++++ b/RepositoryExternal.mk
+@@ -3875,6 +3875,7 @@ endef
+ define gb_Executable__register_gengal
+ $(call gb_Executable_add_runtime_dependencies,gengal,\
+ $(call gb_Library_get_target_for_build,$(CPPU_ENV_FOR_BUILD)_uno) \
++ $(call gb_Library_get_target_for_build,localedata_en) \
+ $(if $(filter MACOSX,$(OS_FOR_BUILD)),$(call gb_Library_get_target_for_build,vclplug_osx)) \
+ $(if $(filter WNT,$(OS_FOR_BUILD)),$(call gb_Library_get_target_for_build,vclplug_win)) \
+ $(if $(filter host,$(gb_Side)),$(call gb_Package_get_target,postprocess_images)) \
+diff --git a/solenv/gbuild/extensions/pre_BuildTools.mk b/solenv/gbuild/extensions/pre_BuildTools.mk
+index e08906068d246..84e2ea533673f 100644
+--- a/solenv/gbuild/extensions/pre_BuildTools.mk
++++ b/solenv/gbuild/extensions/pre_BuildTools.mk
+@@ -47,7 +47,6 @@ gb_BUILD_TOOLS = \
+ $(foreach executable,$(gb_BUILD_TOOLS_executables),$(call gb_Executable_get_runtime_dependencies,$(executable))) \
+ $(foreach executable,$(gb_BUILD_TOOLS_executables_extern),$(call gb_ExternalExecutable_get_dependencies,$(executable))) \
+ $(INSTROOT)/$(LIBO_URE_ETC_FOLDER)/$(call gb_Helper_get_rcfile,uno) \
+- $(if $(WITH_GALLERY_BUILD),$(call gb_Library_get_target,localedata_en)) \
+
+ endif
+