summaryrefslogtreecommitdiff
path: root/app-office/joplin-desktop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
commit2a8d2f71d1d9963368e0ef3d641d75979a689d12 (patch)
tree83e283f960ab2ebbc1a042b8ed6c37b78d47b37b /app-office/joplin-desktop
parent8435c842b9e8fbb2bcc80397ab3aa655000459e2 (diff)
gentoo auto-resync : 04:07:2024 - 08:06:07
Diffstat (limited to 'app-office/joplin-desktop')
-rw-r--r--app-office/joplin-desktop/Manifest2
-rw-r--r--app-office/joplin-desktop/joplin-desktop-3.0.12.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/app-office/joplin-desktop/Manifest b/app-office/joplin-desktop/Manifest
index 206361b0ac70..449a69bf03ed 100644
--- a/app-office/joplin-desktop/Manifest
+++ b/app-office/joplin-desktop/Manifest
@@ -1,3 +1,5 @@
+DIST Joplin-3.0.12.AppImage 239283737 BLAKE2B 69c18d9cd77e0352a3c21e0225f9d6b866f5d1983a66700bb4a9fcd87c0c4476dbe292f0b1a7a3b8962c9dfef1d518501933a509772cd06661991e0edddb5fc3 SHA512 e53448e5cca06a33b16bef12df447b52b00287c0c73658523a261145efb8d3877dd662ff256a96d612b82390fed9431e8377baf16a0c28d1f6fc1062c2cde06a
DIST Joplin-3.0.2.AppImage 253581812 BLAKE2B aa125e8bae0af2ff2e156378d221fd09dda43452b003da36486a59abb7323f81999242475450ab7e164712a060be4f59de68cfcf0736b5237db0e6f0b2914164 SHA512 da53055e23c8bf87e630bf2546c959b2b7a97d65193893c421793259055318ef5ba72f1ca897bcd60e76cc1f060db4f2bc4a39303640872301a7984dd4d7620a
+EBUILD joplin-desktop-3.0.12.ebuild 2371 BLAKE2B 75f8638b02d789e48e0ab968aa862886478dfb8da8025ce1bb5ed014e6b0076c2dd1228c048ed0ee784310549a688096060446c7063e61a3057ef5d1a1ea7833 SHA512 f745f089a455cc3cf92a2ab4a1c443727002666ec951d0d47341899e852ec3c90334a1645a21d866ec105f9a953f2a8bab99c8f4b591ce577a6ecb55d11d782a
EBUILD joplin-desktop-3.0.2.ebuild 2370 BLAKE2B c31b3c291b6f68af1e6fc7857d696c0fb887fbb0a569351bd988e3aed51fc53649df0adb6ec74df71632dcbad718f36be945097507ed4003f2102d7f619e8a3f SHA512 6091bf7ca2898bf48bc15a9e4f004ff39c5b4546c3f39c390aa6a026603c1ac51d53568f71bc4df13252ebee23f7d8ef99da51013edaaeeec0bf03ba692d0eec
MISC metadata.xml 755 BLAKE2B 2f95bccd9fb7bf21b253a524950c4775273c2d1911ebf4b90a392f8c2c7f38e986af0fbd217287595ba39a684609d8df6f275e146388aa0331169e51ba6fc823 SHA512 b62f1dfc822413386115305900866f6cf16fc2071425d2f0f515f537a29bf282d65c31b7f59ccf9187280456eb759a5fcce7340fb983ff0f50413c649c8fc1d0
diff --git a/app-office/joplin-desktop/joplin-desktop-3.0.12.ebuild b/app-office/joplin-desktop/joplin-desktop-3.0.12.ebuild
new file mode 100644
index 000000000000..a9c365263d83
--- /dev/null
+++ b/app-office/joplin-desktop/joplin-desktop-3.0.12.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: This is a Electron app (oh my) and the upstream only provides AppImages.
+
+EAPI=8
+
+APPIMAGE="Joplin-${PV}.AppImage"
+
+inherit desktop xdg
+
+DESCRIPTION="Secure note taking and to-do app with synchronization capabilities"
+HOMEPAGE="https://joplinapp.org/
+ https://github.com/laurent22/joplin/"
+SRC_URI="https://github.com/laurent22/joplin/releases/download/v${PV}/${APPIMAGE}"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libcanberra[gtk3]
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ mkdir -p "${S}" || die
+ cp "${DISTDIR}/${APPIMAGE}" "${S}" || die
+
+ cd "${S}" || die # "appimage-extract" unpacks to current directory.
+ chmod +x "${S}/${APPIMAGE}" || die
+ "${S}/${APPIMAGE}" --appimage-extract || die
+}
+
+src_prepare() {
+ # Fix permissions.
+ find "${S}" -type d -exec chmod a+rx {} + || die
+ find "${S}" -type f -exec chmod a+r {} + || die
+
+ default
+}
+
+src_install() {
+ cd "${S}/squashfs-root" || die
+
+ insinto /usr/share
+ doins -r ./usr/share/icons
+
+ local apphome="/opt/${PN}"
+ local toremove=(
+ .DirIcon
+ @joplinapp-desktop.desktop
+ @joplinapp-desktop.png
+ AppRun
+ LICENSE.electron.txt
+ LICENSES.chromium.html
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm64
+ resources/app.asar.unpacked/node_modules/node-notifier
+ usr
+ )
+ rm -f -r "${toremove[@]}" || die
+
+ mkdir -p "${ED}/${apphome}" || die
+ cp -r . "${ED}/${apphome}" || die
+
+ dosym -r "${apphome}/@joplinapp-desktop" "/usr/bin/${PN}"
+ make_desktop_entry "${PN}" Joplin @joplinapp-desktop "Office;" \
+ "StartupWMClass=Joplin\nMimeType=x-scheme-handler/joplin;"
+}