summaryrefslogtreecommitdiff
path: root/app-office/homebank
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
commit59c2499e0c9720169c9d5a02168c51c807a21467 (patch)
tree48c68a8a7e0094b2edaace12850e6c059bc3636b /app-office/homebank
parenta25cc082a26782e5d39ded4559c91ff11bc3c299 (diff)
gentoo auto-resync : 14:05:2024 - 00:01:24
Diffstat (limited to 'app-office/homebank')
-rw-r--r--app-office/homebank/Manifest4
-rw-r--r--app-office/homebank/homebank-5.8.ebuild45
-rw-r--r--app-office/homebank/metadata.xml5
3 files changed, 52 insertions, 2 deletions
diff --git a/app-office/homebank/Manifest b/app-office/homebank/Manifest
index fe94eee58b3c..9f4a100fe932 100644
--- a/app-office/homebank/Manifest
+++ b/app-office/homebank/Manifest
@@ -1,3 +1,5 @@
DIST homebank-5.7.4.tar.gz 3670067 BLAKE2B 3be94dc9e1ec11fc67fb7dab1655c9e2ab8529887cba200331e938b02a97abf810d94823443de0f5faf1b6beda85f9208e26909a876c3828ae2a1aab38890db0 SHA512 d65127b49a7566f5ad88feb8c614883c43e322ea50d915e49691b169771fac222573da4988ab1c54d9f39b9dfdf2d724cba07269e093c67a04900828d0b87093
+DIST homebank-5.8.tar.gz 3714120 BLAKE2B 72c8f635a6328df767cb2d94195dccf067cec98266c820e3fcfd764886aaffd5341130b6102e7e56b6623dfc2f78658a5dcad7f23839e0091c0d10a8674b2a4f SHA512 c004cdb88e905d24554ecc52632ca92d5a13ffd61addfdea3374a09ea6f53b848a9f92f4b3eebae06550d72898fd318482c8ab21cb0bb2366c63ff89ac0f349d
EBUILD homebank-5.7.4.ebuild 814 BLAKE2B 0f131af50cca25e3dbd57482e534511e9e6c1b2943700479ce9593f95422d4555196a11301a4238fe12b9f4fb69d7a43ec4d197ccb9969963a7c2e4110b6fe00 SHA512 401467a50015625c37b037545f888a50748784d96a2eeffb34e3b5a0c1b51ce7b4aff0e12f119f03c370da4487a490e43ddda19dbdb2e4e440df1d1e84be0568
-MISC metadata.xml 244 BLAKE2B 39c374b3b40c30a49f2ac1206e2ebedbc17895997225764b72cfa0496c66c3f52ba17c12edf788a96bb83d07372ee517d2444db18399c2321e9c1cea55382966 SHA512 125b08a8b50354d1a58c656385743742bd2da7946479fd738aa5e0ba3b62df983920c737436f34f56ff873969cde5a748271051e3f2a5be57de023114f25ebe3
+EBUILD homebank-5.8.ebuild 817 BLAKE2B 164cc4ac83ec8e2745b47b304d207ac7959f1ce558f3d5a1995fb35363bcc75d0fd4ed5013c3d7553349ee3b0ee8cd7a42c061b3184ec1aa65329c2403d9a113 SHA512 d6dc0e4a2817dfcdf89ef6428b8332bd6b4a147f3709a36e8fd80730eb27e38f6292e294fc78050bc69384b69765f8e47d65615beb70a5b3c829cc80dfdf6bf2
+MISC metadata.xml 322 BLAKE2B f0ed3691f77c7dba631ced8827fc442dec42c7cae9c07f66e69304ad862112233defc63cb443c5321b3ffc385976ae3b46165d3e31318e564e35ee01b1875d05 SHA512 449b8694aa9236e7925b62ba3249bff5d567a3710ac8ade8db75a5403dd0bb58380717c15fe42cc082beeee3030aa65ce90d047f18a1d67d19dd50771315f013
diff --git a/app-office/homebank/homebank-5.8.ebuild b/app-office/homebank/homebank-5.8.ebuild
new file mode 100644
index 000000000000..477ea294339b
--- /dev/null
+++ b/app-office/homebank/homebank-5.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="
+ https://www.gethomebank.org/
+ https://launchpad.net/homebank
+"
+SRC_URI="https://www.gethomebank.org/public/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.39:2
+ net-libs/libsoup:3.0
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3:= )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf $(use_with ofx)
+}
diff --git a/app-office/homebank/metadata.xml b/app-office/homebank/metadata.xml
index 464c803f33d3..cf071defb446 100644
--- a/app-office/homebank/metadata.xml
+++ b/app-office/homebank/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>arkamar@gentoo.org</email>
+ <name>Petr Vaněk</name>
+ </maintainer>
<upstream>
<remote-id type="launchpad">homebank</remote-id>
</upstream>