summaryrefslogtreecommitdiff
path: root/app-office/homebank/homebank-5.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-05 15:17:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-05 15:17:03 +0000
commit8afe4133ba3d8586301516885427809020a3cafa (patch)
treed82e1b009614ffe9efc4767af2297efd6365303f /app-office/homebank/homebank-5.6.1.ebuild
parenta0c1504c093bc6abe04f9d96018f6252f81cd9ab (diff)
gentoo auto-resync : 05:02:2023 - 15:17:02
Diffstat (limited to 'app-office/homebank/homebank-5.6.1.ebuild')
-rw-r--r--app-office/homebank/homebank-5.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-office/homebank/homebank-5.6.1.ebuild b/app-office/homebank/homebank-5.6.1.ebuild
new file mode 100644
index 000000000000..2e1c67a5408b
--- /dev/null
+++ b/app-office/homebank/homebank-5.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit xdg
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.39:2
+ >=net-libs/libsoup-2.26:2.4
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3:= )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND=">=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf $(use_with ofx)
+}