summaryrefslogtreecommitdiff
path: root/app-office/gnumeric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-office/gnumeric
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest2
-rw-r--r--app-office/gnumeric/gnumeric-1.12.48.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 8701268d4bda..514cb0d34fbb 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,3 +1,5 @@
DIST gnumeric-1.12.47.tar.xz 18309764 BLAKE2B 8b800a6749d208a445abfc7189618abb20907118f274b313cf81436ab3665d50edeab4c49b03adea505448138bd32b8d3efcd041eba54342d9fb293c574cac08 SHA512 f6298fee752b062672acc20e18388d7424719d69ce9586888f33be07ca92bbd7d99e46b98e9ab2a546d1954d3113b59a5105d46c4e8a13e65e1ae9acc38391ab
+DIST gnumeric-1.12.48.tar.xz 18329300 BLAKE2B f38fdc14dbe2b45fa3c2ebbfb94d89c85f6c04bdc95b493a760a23ba347fa99d2515f0e7fc0a2f45e31c3f2a3b0c8b425b0fb876f59215e2da76348c5dbe116a SHA512 6c17e95ecd88b43da0f4f23d9c99dad5d0016f9618570a36be5998fa84c144bb5d13749fd9c4fe0c295e3c80d70c717d09763cc9904dfc1df062b96749b73ebc
EBUILD gnumeric-1.12.47.ebuild 2291 BLAKE2B 773493d673d5aaa1106e4ec80e55370dc5f90fe1f4ea673a53406565771862da27fd1a3194a84e5c9cf30bc6ba5ce11a6232d2ba63c107981ea601c188f788ca SHA512 6894fbdf3b90d821fd3b630d86dc054c705cd9158b605d8f914074dc3ad37b4a9af826a5ba692899f1fff412a752a77a6434a2435b03c40aeaa7eb52b0095f6f
+EBUILD gnumeric-1.12.48.ebuild 2293 BLAKE2B b333b9635420b343fb94eeb9e8fa2eab361261498e54b0cef5066fc964347671849ee5b9baf1f4ccf6a77c72e8c96b26da11f8294c1e342dacc5c9db233cbd9b SHA512 4375b3a95752a79284534153f776ac56d36ff6e132d29457599519130ad887f3e25b2c95f4d9814916440723e84942bee0e45cbccd631dd4c13534a18495a56c
MISC metadata.xml 519 BLAKE2B 07b0ba6ff606de990d5fb97de46aa20f0581ab63f789f2238446e6f87dc93283a0873dfec3ee4a3fd38372aa3fa17e50349abffbd5eb5cc73d4cbdbffe1e5592 SHA512 a03730e0ccc7c2fb4df57f0d63da93e9254c8df99594a26215ff9919302919eb0bfdd21622b9d73f84011c5cd28397cc0b5b2add2fce0624d7a59fc1877601d3
diff --git a/app-office/gnumeric/gnumeric-1.12.48.ebuild b/app-office/gnumeric/gnumeric-1.12.48.ebuild
new file mode 100644
index 000000000000..0bee6e045c87
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.48.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit gnome.org libtool python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.48:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}