summaryrefslogtreecommitdiff
path: root/app-office/gnucash/gnucash-3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /app-office/gnucash/gnucash-3.6.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'app-office/gnucash/gnucash-3.6.ebuild')
-rw-r--r--app-office/gnucash/gnucash-3.6.ebuild31
1 files changed, 23 insertions, 8 deletions
diff --git a/app-office/gnucash/gnucash-3.6.ebuild b/app-office/gnucash/gnucash-3.6.ebuild
index 9999712e8bfd..ec42d91eaae7 100644
--- a/app-office/gnucash/gnucash-3.6.ebuild
+++ b/app-office/gnucash/gnucash-3.6.ebuild
@@ -3,23 +3,20 @@
EAPI=6
-# google{test,mock} version
-GV="1.8.0"
PYTHON_COMPAT=( python3_{4,5,6} )
inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
DESCRIPTION="A personal finance manager"
HOMEPAGE="http://www.gnucash.org/"
-SRC_URI="https://github.com/Gnucash/${PN}/releases/download/${PV}/${P}.tar.bz2
- https://github.com/google/googletest/archive/release-${GV}.tar.gz -> gtest-${GV}.tar.gz"
+SRC_URI="https://github.com/Gnucash/${PN}/releases/download/${PV}/${P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="aqbanking chipcard debug doc examples gnome-keyring +gui mysql nls ofx
- postgres python quotes -register2 sqlite"
+ postgres python quotes -register2 sqlite test"
REQUIRED_USE="
chipcard? ( aqbanking )
@@ -70,12 +67,12 @@ RDEPEND="
"
DEPEND="${RDEPEND}
- ~dev-cpp/gtest-${GV}
>=sys-devel/gettext-0.19.6
dev-lang/perl
dev-perl/XML-Parser
sys-devel/libtool
virtual/pkgconfig
+ test? ( >=dev-cpp/gtest-1.8.0 )
"
PDEPEND="doc? (
@@ -104,8 +101,6 @@ src_configure() {
fi
local mycmakeargs=(
- -DGMOCK_ROOT="${WORKDIR}"/googletest-release-${GV}/googlemock
- -DGTEST_ROOT="${WORKDIR}"/googletest-release-${GV}/googletest
# Disable fallback to guile-2.0
-DCMAKE_DISABLE_FIND_PACKAGE_GUILE2=ON
-DCOMPILE_GSCHEMAS=OFF
@@ -127,6 +122,26 @@ src_test() {
"${BUILD_DIR}"/common/test-core/ || die
fi
+ LOCALE_TESTS=
+ if type locale >/dev/null 2>&1; then
+ MY_LOCALES="$(locale -a)"
+ if [[ "${MY_LOCALES}" != *en_US* ||
+ "${MY_LOCALES}" != *en_GB* ||
+ "${MY_LOCALES}" != *fr_FR* ]] ; then
+ ewarn "Missing one or more of en_US, en_GB, or fr_FR locales."
+ else
+ LOCALE_TESTS=true
+ fi
+ else
+ ewarn "'locale' not found."
+ fi
+
+ if [[ ! ${LOCALE_TESTS} ]]; then
+ ewarn "Disabling test-qof and test-gnc-numeric."
+ echo 'set(CTEST_CUSTOM_TESTS_IGNORE test-qof test-gnc-numeric)' \
+ > "${BUILD_DIR}"/CTestCustom.cmake || die
+ fi
+
cd "${BUILD_DIR}" || die
XDG_DATA_HOME="${T}/$(whoami)" emake check
}