summaryrefslogtreecommitdiff
path: root/app-office/gnome-todo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-office/gnome-todo
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-office/gnome-todo')
-rw-r--r--app-office/gnome-todo/Manifest1
-rw-r--r--app-office/gnome-todo/gnome-todo-9999.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-office/gnome-todo/Manifest b/app-office/gnome-todo/Manifest
index 5248fa1de81d..02860ae65613 100644
--- a/app-office/gnome-todo/Manifest
+++ b/app-office/gnome-todo/Manifest
@@ -2,4 +2,5 @@ AUX fix-build-with-meson-0.61.patch 632 BLAKE2B 03d85c1ff1c5d6eaa180f9e299423c43
AUX gnome-todo-eds-libecal-2.0.patch 18614 BLAKE2B 7754300bfe27317ddb5242b35f394a50a57f6d0b019dbcc7de35614f05d8a5be272f93d40b9b990bdcf912c34160caed05e99a7faa15818bffaaacebbd628ab5 SHA512 f04a34472ba2f38734086bb31a12d8493ec6ddd2bb2bc0ef2c1e9274fefa8faec51014f478d8d09bbf4bb5cafbdc1d170393b7a50ecfa22e26d5bed497a6183b
DIST gnome-todo-3.28.1.tar.xz 751448 BLAKE2B 55c4909d35e65a763bd283e55b85dc3a6dc0190c39f3f97c33bde7c071abd8e7a88479ed72733e66bd550133bb683ed9cafb9dff36f41b4f7d6bcb9f889f2a39 SHA512 26371dd2a460656b5b7d323420cfdc3f26c548cabe0bf6a01081a017d68e062fb54164f6d0c5cf5054b59f30be65681dedde450d9b98b88f73c07131cd01f57a
EBUILD gnome-todo-3.28.1-r1.ebuild 1659 BLAKE2B 9be551988d966133dc1f6768871517c994a90d36432ab41f9d6897b53475ca2284ec97d29f1a5c1a5a64552c032db999aa8f2c966f84e9444efb5e12a76722fd SHA512 39097c89666f616e550bdbf6dc271d0476eb45e4336d615123c040ce8e627abc952b0603bd0a751aff2f03a5ed3eb379c637b40b4271d59a8e3c07e6ecdf64fd
+EBUILD gnome-todo-9999.ebuild 1568 BLAKE2B f775e13fca2945e42678a61f97687aeb42f76e808e1765735b3088419d49bbdde123222a047fd27f412d08ae229fb5b058abbbdd1b99d4de5e63fe4141f9ad0e SHA512 bebfe3d9e364f585b0d494784eb1aa442595d13dbd419bc1abca644e6f5f825352df4191eea3c9f3bf9dc4bc93afa72bc44e9e4b7d270a7a7c0f113c8f1d50b4
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/app-office/gnome-todo/gnome-todo-9999.ebuild b/app-office/gnome-todo/gnome-todo-9999.ebuild
new file mode 100644
index 000000000000..0ef934158147
--- /dev/null
+++ b/app-office/gnome-todo/gnome-todo-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Personal task manager"
+HOMEPAGE="https://wiki.gnome.org/Apps/Todo https://gitlab.gnome.org/GNOME/gnome-todo"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gnome-todo.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.58.0:2
+ >=gui-libs/gtk-3.92.0:4[introspection?]
+ gui-libs/libadwaita:1
+ >=net-libs/gnome-online-accounts-3.25.3
+ >=dev-libs/libpeas-1.17
+ dev-libs/libportal:0=[gtk]
+ >=gnome-extra/evolution-data-server-3.33.2:=[gtk]
+ net-libs/rest:0.7
+ dev-libs/json-glib
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # TODO: There aren't any consumers of the introspection outside gnome-todo's own plugins, so maybe we
+ # TODO: should just always build introspection support as an application that needs it for full functionality?
+ # Todoist plugin requires 3.25.3 GOA for being able to add a Todoist account
+ local emesonargs=(
+ $(meson_use introspection)
+ -Dtracing=false
+ -Dprofile=default
+
+ -Dtodo_txt_plugin=true
+ -Dtodoist_plugin=true
+ -Dunscheduled_panel_plugin=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}