summaryrefslogtreecommitdiff
path: root/app-office/eqe/eqe-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/eqe/eqe-1.3.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/eqe/eqe-1.3.0.ebuild')
-rw-r--r--app-office/eqe/eqe-1.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-office/eqe/eqe-1.3.0.ebuild b/app-office/eqe/eqe-1.3.0.ebuild
new file mode 100644
index 000000000000..c7eb1bc46ea9
--- /dev/null
+++ b/app-office/eqe/eqe-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils
+
+DESCRIPTION="A small LaTeX editor that produces images, with drag and drop support"
+HOMEPAGE="http://rlehy.free.fr/"
+SRC_URI="http://rlehy.free.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="dev-perl/Gtk2
+ dev-perl/File-Slurp
+ dev-perl/Template-Toolkit
+ media-gfx/imagemagick
+ virtual/latex-base"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix install loction and conform to the Gentoo way
+ epatch "${FILESDIR}"/${P}-Makefile.patch || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}