summaryrefslogtreecommitdiff
path: root/app-office/dia
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/dia
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/dia')
-rw-r--r--app-office/dia/Manifest6
-rw-r--r--app-office/dia/dia-0.97.3.ebuild104
-rw-r--r--app-office/dia/files/dia-0.97.0-gnome-doc.patch61
-rw-r--r--app-office/dia/files/dia-0.97.2-underlinking.patch27
-rw-r--r--app-office/dia/files/dia-0.97.3-freetype_pkgconfig.patch66
-rw-r--r--app-office/dia/metadata.xml16
6 files changed, 280 insertions, 0 deletions
diff --git a/app-office/dia/Manifest b/app-office/dia/Manifest
new file mode 100644
index 000000000000..322c5d13b8d0
--- /dev/null
+++ b/app-office/dia/Manifest
@@ -0,0 +1,6 @@
+AUX dia-0.97.0-gnome-doc.patch 1961 BLAKE2B 6b6835a487e4b1ada0a1e67cb3ce123b0b4b3e67c86e9478ac0f401ae70f8f1381ef068a2ca6e116313db42d09bdb7abb523bf9a34856a1a39f7e4b0c9c3a84f SHA512 5200051f19d4a199f8c4e17e5f23c16ad4c13a9531b843be0a4d491aa8884efd4d90e6850c1cd1488e80b344ff18e5dc2b2ad7e57cb7417b6c574ad1e8d6f186
+AUX dia-0.97.2-underlinking.patch 1024 BLAKE2B 32fa473b806e740fb7c2b0e04c170c746bf523088e85dce281d0c87ef10c1542f1d77414dd49e6ce48b1e54c2e3e48d09c1820a8739bce6bb64539ba87b2485e SHA512 d45eb49c39227e9f11ce999083de0a83c60bfac2a5db2403e4bf083c275efdef6bd1adca678712253ec53f7b3d22a5c23f6f886839c32e6cb07a93c001f45e2e
+AUX dia-0.97.3-freetype_pkgconfig.patch 2574 BLAKE2B 870617b939e4ab7ecdfbf5bba4e78cee9f34ee10b1de2bb85380cc96d31c319132861b8ddd0e89a5a03cae2578588c9483ba62f0bf4006096c4074beef77cc4f SHA512 0e937bb17cb69d3f266f68658b11b209a913300d2366adfa4bb608212cd82f00d85272be784f0442d0dcba8659d020e5e848d2e02ee7310ec8cfd6c7170aa8b7
+DIST dia-0.97.3.tar.xz 5548500 BLAKE2B ab476ce48e57c1def01095a8d6d92208c11817580cfca1cfcf38af12943153116b31149ca187c65e5121ef9fb281bacc4c3e7f1726ed23b46ba14902faaaa34f SHA512 34298980be930b87cb4a636344e4cb2a7e43eedc00b0969a5e446cee9b74b616fdc8c798efcb9a5832b98741f2e20632a44037b2bcb436f59591d531ef441efa
+EBUILD dia-0.97.3.ebuild 2897 BLAKE2B 44185686c3917301de997ff8d92fe03b3904da91501ceb8099f5a7238f79c22ea380c59a6ab51cc62eb5fc6e12b2ea99e60f1a7b6fa50ca323423f12ccf2ee23 SHA512 d854e5b558da37a49a12e8213f65f6a5211da77b63b2b5d3596d3f0a803997f9a3f9ad254b0a68dd7d6e375363b6a25c93b996d32c4a4baa58073b436aa7937e
+MISC metadata.xml 668 BLAKE2B 8efd2b23ae5c96f9c65cae27602a4e8a969d279b2400c0e5940541d2d9066ce0f5dcbb39e9a5dabf6ce8391f57d1b527a89bb7a015153922b378d40c121342c6 SHA512 2296acdf1f56496eb699d6acfc85ec64e1c514dc01184df367c77b505f8765d45b51d7753e1d6bcb5cb80cb239f6a05b0fcda9ddc412f7d72ed4a4a4733ea6ed
diff --git a/app-office/dia/dia-0.97.3.ebuild b/app-office/dia/dia-0.97.3.ebuild
new file mode 100644
index 000000000000..a8a9ae6b6c07
--- /dev/null
+++ b/app-office/dia/dia-0.97.3.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+GCONF_DEBUG=yes
+GNOME2_LA_PUNT=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-single-r1 multilib
+
+DESCRIPTION="Diagram/flowchart creation program"
+HOMEPAGE="https://wiki.gnome.org/Apps/Dia"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+# the doc USE flag doesn't seem to do anything without docbook2html
+# cairo support is preferred as explained by upstream at:
+# https://bugzilla.gnome.org/show_bug.cgi?id=729668#c6
+IUSE="+cairo doc python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/glib-2:2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/popt
+ >=media-libs/freetype-2
+ >=media-libs/libart_lgpl-2
+ media-libs/libpng:0
+ sys-libs/zlib
+ x11-libs/gtk+:2
+ x11-libs/pango
+ cairo? ( x11-libs/cairo )
+ doc? (
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets )
+ python? (
+ >=dev-python/pygtk-2
+ ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-apps/sed
+ virtual/pkgconfig
+ doc? ( dev-libs/libxslt )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog KNOWN_BUGS MAINTAINERS NEWS README RELEASE-PROCESS THANKS TODO"
+
+ epatch "${FILESDIR}"/${PN}-0.97.0-gnome-doc.patch #159381 , upstream #470812 #558690
+ epatch "${FILESDIR}"/${PN}-0.97.2-underlinking.patch #420685, upstream #678761
+ epatch "${FILESDIR}"/${PN}-0.97.3-freetype_pkgconfig.patch #654814, upstream https://gitlab.gnome.org/GNOME/dia/merge_requests/1
+
+ if use python; then
+ python_fix_shebang .
+ fi
+
+ if ! use doc; then
+ # Skip man generation
+ sed -i -e '/if HAVE_DB2MAN/,/endif/d' doc/*/Makefile.am || die
+ fi
+
+ # Fix naming conflict on Darwin/OSX, upstream bug #723869
+ sed -i -e 's/isspecial/char_isspecial/' objects/GRAFCET/boolequation.c || die
+
+ # Upstream bug #737254
+ sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
+
+ # Upstream bug #737255
+ sed -i -e "/localedir/d" configure.in || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --exec-prefix makes Python look for modules in the Prefix
+ # --enable-gnome only adds support for deprecated stuff, bug #442294
+ # https://bugzilla.redhat.com/show_bug.cgi?id=996759
+ gnome2_src_configure \
+ --exec-prefix="${EPREFIX}/usr" \
+ --disable-gnome \
+ --disable-libemf \
+ $(use_enable doc db2html) \
+ $(use_with cairo) \
+ $(use_with python) \
+ --without-swig \
+ --without-hardbooks
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Install second desktop file for integrated mode (bug #415495, upstream #588208)
+ sed -e 's|^Exec=dia|Exec=dia --integrated|' \
+ -e '/^Name/ s|$| (integrated mode)|' \
+ "${ED}"/usr/share/applications/dia.desktop \
+ > "${ED}"/usr/share/applications/dia-integrated.desktop || die
+}
diff --git a/app-office/dia/files/dia-0.97.0-gnome-doc.patch b/app-office/dia/files/dia-0.97.0-gnome-doc.patch
new file mode 100644
index 000000000000..63e13deaf22f
--- /dev/null
+++ b/app-office/dia/files/dia-0.97.0-gnome-doc.patch
@@ -0,0 +1,61 @@
+From 9d40692b695b30f80b263814bdd351c0dbe67733 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 18 May 2009 22:19:35 +0200
+Subject: [PATCH] Fix compilation in a gnome environment, gentoo bug #159831
+
+---
+ configure.in | 19 +++++++++++--------
+ 1 files changed, 11 insertions(+), 8 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index d27ee6e..d9c0bf4 100644
+--- a/configure.in
++++ b/configure.in
+@@ -110,17 +110,19 @@ if test "$have_libart" = "yes" ; then
+ fi
+
+ AC_MSG_CHECKING([whether GNOME specific code should be used])
+-AC_ARG_ENABLE(gnome,[ --enable-gnome enable gnome code],
+- GNOME=$enableval, GNOME=no)
+-if test "$GNOME" = "yes" ; then
++AC_ARG_ENABLE(gnome,
++ AC_HELP_STRING([--enable-gnome],[enable gnome code]),,
++ enable_gnome=no)
++if test "x$enable_gnome" = "xyes" ; then
+ GTK_MODULES="$GTK_MODULES libgnome-2.0 libgnomeui-2.0"
+ AC_DEFINE(GNOME,1,[Define if building with GNOME support])
++ AC_DEFINE(HAVE_GNOME,1,[Define if building with GNOME support])
+ AC_DEFINE_UNQUOTED(GNOME_ICONDIR, "${prefix}/share/pixmaps", [GNOME icon directory])
+- have_gnome=true
++ have_gnome=yes
+ else
+- have_gnome=false
++ have_gnome=no
+ fi
+-AM_CONDITIONAL(HAVE_GNOME, $have_gnome)
++AM_CONDITIONAL(HAVE_GNOME, [test "x$have_gnome" != "xno"])
+ AC_MSG_RESULT($GNOME)
+
+ dnl GTK2: libgnomecanvas-2.0 ?
+@@ -129,7 +131,8 @@ PKG_CHECK_MODULES(GTK,$GTK_MODULES)
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
+-AM_CONDITIONAL(HAVE_BONOBO,false)
++#AM_CONDITIONAL(HAVE_BONOBO,false)
++AM_CONDITIONAL(HAVE_BONOBO,[test "true" = "false"])
+
+ dnl Look for Cairo
+ AC_ARG_WITH(cairo,
+@@ -627,7 +630,7 @@ Configuration:
+ Source code location: ${srcdir}
+ Compiler: ${CC}
+
+- Gnome support: ${GNOME}
++ Gnome support: ${have_gnome}
+ Python support: ${with_python}
+ Libart support (PNG export): ${have_libart}
+ Cairo support (PNG, PDF, print): ${with_cairo}
+--
+1.6.3
+
diff --git a/app-office/dia/files/dia-0.97.2-underlinking.patch b/app-office/dia/files/dia-0.97.2-underlinking.patch
new file mode 100644
index 000000000000..903e077f23f4
--- /dev/null
+++ b/app-office/dia/files/dia-0.97.2-underlinking.patch
@@ -0,0 +1,27 @@
+From 2f853bab67b087605a10f544a7df780ac98b8583 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <gentoo@mgorny.alt.pl>
+Date: Sat, 7 Jul 2012 17:28:59 +0200
+Subject: [PATCH] Fix missing linkage with gmodule-2.0.
+
+Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=678761
+Fixes: https://bugs.gentoo.org/show_bug.cgi?id=420685
+---
+ dia-0.97.2/configure.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dia-0.97.2/configure.in b/dia-0.97.2/configure.in
+index 72830de..6b7394a 100644
+--- a/dia-0.97.2/configure.in
++++ b/dia-0.97.2/configure.in
+@@ -55,7 +55,7 @@ AC_SUBST(GMODULE_CFLAGS)
+ AC_SUBST(GMODULE_LIBS)
+ AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
+
+-GTK_MODULES="gtk+-2.0 >= 2.6.0 glib-2.0 >= 2.6.0 libxml-2.0 gdk-pixbuf-2.0 gthread-2.0"
++GTK_MODULES="gtk+-2.0 >= 2.6.0 glib-2.0 >= 2.6.0 libxml-2.0 gdk-pixbuf-2.0 gthread-2.0 gmodule-2.0"
+ PKG_CHECK_MODULES(PANGOVERSION, pango >= 1.8.0, ,
+ AC_MSG_ERROR([Need Pango version 1.8.0 or higher]))
+
+--
+1.7.11.1
+
diff --git a/app-office/dia/files/dia-0.97.3-freetype_pkgconfig.patch b/app-office/dia/files/dia-0.97.3-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..c48b5ba66fbf
--- /dev/null
+++ b/app-office/dia/files/dia-0.97.3-freetype_pkgconfig.patch
@@ -0,0 +1,66 @@
+--- dia-0.97.3/configure.in
++++ dia-0.97.3/configure.in
+@@ -62,43 +62,26 @@
+
+ AC_ARG_WITH(freetype,
+ [ --without-freetype compile without FreeType support],,with_freetype=yes)
+-if test "x$with_freetype" = "xyes"; then
+-PKG_CHECK_MODULES(PANGOFT2,pangoft2,have_pangoft2=true,have_pangoft2=false)
+-if test "$have_pangoft2" = "true"; then
+- dnl On Solaris with Forte C, at least, need to link app/dia with -lfreetype.
+- dnl It's not enough that -lpangoft2 implicitly pulls it in.
+- have_freetype=false
+- AC_CHECK_LIB(freetype,FT_Init_FreeType,have_freetype=true,have_freetype=false,`freetype-config --libs`)
+- if test "$have_freetype" = "true"; then
+- dnl Need 2.0.9, as a bug was fixed for us there.
+- dnl However, freetype-config doesn't give a meaningful version, so we must
+- dnl do it like this.
+- AC_MSG_CHECKING([if FreeType version is 2.0.9 or higher])
+- old_CPPFLAGS="$CPPFLAGS"
+- CPPFLAGS="$CPPFLAGS `freetype-config --cflags`"
+- AC_TRY_CPP([#include <ft2build.h>
+-#include FT_FREETYPE_H
+-#if (FREETYPE_MAJOR*1000+FREETYPE_MINOR)*1000+FREETYPE_PATCH < 2000009
+-#error Freetype version too low.
+-#endif
+-],
+- [AC_MSG_RESULT(yes)
+- FREETYPE_LIBS=`freetype-config --libs`
+- AC_SUBST(FREETYPE_LIBS)
+- FREETYPE_CFLAGS=`freetype-config --cflags`
+- AC_SUBST(FREETYPE_CFLAGS)
+- GTK_MODULES="$GTK_MODULES pangoft2"
+- AC_DEFINE(HAVE_FREETYPE,1,[Define if you have the FreeType2 library])]
+- ,
+- [AC_MSG_ERROR([Need FreeType library version 2.0.9 or higher])])
+- CPPFLAGS="$old_CPPFLAGS"
+- else
+- AC_MSG_ERROR(Can't find FreeType library)
+- fi
+-else
+- AC_MSG_ERROR(Can't find PangoFT2 library)
+-fi
+-fi
++AS_IF([test "x$with_freetype" = "xyes"],[
++ dnl freetype2.pc uses the libtool specific version number and not the
++ dnl package version. See
++ dnl https://git.savannah.gnu.org/cgit/freetype/freetype2.git/tree/docs/VERSIONS.TXT
++ dnl Let's raise minimum dependency to freetype-2.4.0 because that's the
++ dnl lowest freetype libtool version I could find.
++ dnl freetype-2.4.0 is from July 2010 and should be reasonably old
++ dnl enough.
++ PKG_CHECK_MODULES(FREETYPE, freetype2 >= 11.0.5,
++ [
++ CPPFLAGS="$CPPFLAGS $FREETYPE_CFLAGS"
++ AC_DEFINE(HAVE_FREETYPE,1,[Define if you have the FreeType2 library])
++ ],
++ AC_MSG_ERROR([Need FreeType library version 2.4.0 or higher])
++ )
++ PKG_CHECK_MODULES(PANGOFT2,pangoft2,
++ GTK_MODULES="$GTK_MODULES pangoft2",
++ AC_MSG_ERROR(Can't find PangoFT2 library)
++ )
++])
+ AM_CONDITIONAL(WITH_FREETYPE, test "x$with_freetype" != "xno")
+
+ CFLAGS="$FREETYPE_CFLAGS $CFLAGS"
diff --git a/app-office/dia/metadata.xml b/app-office/dia/metadata.xml
new file mode 100644
index 000000000000..0d9bb7d4ae18
--- /dev/null
+++ b/app-office/dia/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <longdescription>
+ Dia is a gtk+ based diagram creation program. It can be used to
+ draw many different kinds of diagrams. It currently has special
+ objects to help draw entity relationship diagrams, UML diagrams,
+ flowcharts, network diagrams, and simple circuits. It is also
+ possible to add support for new shapes by writing simple XML
+ files, using a subset of SVG to draw the shape.
+ </longdescription>
+</pkgmetadata>